My Cloud Home Firmware update

Hello.

I noticed that there’s a new firmware update for MY CLOUD HOME, since May the 13th.
I’m still a new user and the only time I updated my drive was when I bought it a few months ago.

It appears that I will receive a message to install the new firmware update… but I was wondering: is there any way to MANUALLY install that update?

Thank you.

There is no official way to manually install the firmware on the My Cloud Home (MCH), the update will happen automatically OTA (over the air, in this case it is by ethernet). The MCH is made for the home user and by design there is no root access to the Debian based OS and there is no user access to the hard disk. There are hacks to bypass the security but there is no good reason for the home user to that.

Although the Version: 9.6.0-110 update will occur automatically for the MCH, in this case there is no compelling reason to anticipate the firmware update unless you are having problem with ‘enable Local Access’.

My Cloud Home Firmware 9.6.0-110 Release Notes

Version: 9.6.0-110

Release Date: 05/13/2024

Supported Devices: My Cloud Home, My Cloud Home Duo, ibi

Updates In This Release

  • Resolved an issue that was preventing some users to enable Local Access

Thank you for clearing this for me: I’ll have to wait until I get a notification.

I am indeed having problems accessing my local folder. It keeps disappearing. I am aware that I can clear the device settings… but it takes many days to index all my files… only for the folder to disappear again, weeks later… hopefully this update will solve that problem.

(Whenever I try to disable local access I immediately have an ‘internal server error’… not allowing mw to ‘reset’ local accessibility). I’ve had this drive for over a month now… and having access to my local network it’s quite practical. Hopefully the update will stop this from ever happening again.

1 Like

New update didn’t help me with local access problem. Still not workin

1 Like

My update hasn’t arrived yet. I wish that there was a way to manually update.

I’ve only had my cloud home for a month and this is the third time that my local access folder disappeared. Clear the settings creates a very long indexing period. Also if i try to reset my local access, it’s gives me an internal server error… basically, I can’t turn it off. This is really weird…

New update will not solve your problem. Many users (me included) are moving to different brand because since long time ago local access is no longer working.
Clear settings solve problem just for few days

1 Like

That’s quite terrible.

Using s local folder made storing files so easy…

Thanks for lettIng me know of your experience.

Hello Paolo.

Please tell me: how did you get notified? Was it an e-Mail? Did you computer show you a notification?

Thank you.

Latest Firmware was automatically installed. After that I’ve tried to disable local access but I had same error “internal server error”
and I had to delete setting again.
Now I’m triing to restore factory setting (last change), If also this will not work I’ll shutfown this nas for ever (to much time spent on
this issue).

1 Like

Thanks for answering my question.

Indeed, I don’t exactly regret buying this NAS drive… (please be aware that I’ve only had it for over a month). But it’s quite unpractical for me not to have access to the local folder. And to reset the settings makes the NAS drive index the files again (which takes more than a week in my case)…

Let’s see what’s happens once the update occurs… but that ‘Internal Serve Error’ is quite absurd!! It literally doesn’t allow me to ‘reset’ my local folder access…

Please let me know if restoring to factory settings helped you.

Good luck.

Never had to do ‘Clear Device Settings’ after firmware 8.12 because I never allowed Apple macOS apps to write to the My Cloud Home.

You have to take Apple at their word. They don’t want you to store data library on a network drive other than their own iCloud or you will lose data.

And Apple advises against any cloud storage (but its own): Updating from iPhoto to Photos for macOS - Apple Support

1 Like

Thank you for sharing your opinion.

As a side note, a few colleagues whom actually use Windows OS, are having a similar problem.

I guess that, in time, I’ll have to rethink the way I interact between my Mac and this NAS drive.

It is certainly possible with Windows OS, but the frequency is much lower. This file permission errors problem is common with the macOS but is not unique to WD My Cloud Home, as you can see on the Synology forum below, without any solution.

The reason it is prevalent and almost a certainty with macOS is because Apple does not document how they are using the xattrs attribute for files written on the network and this prevents NAS manufacturers from providing support. Apple certainly knows how they are doing it on their own iCloud, they are just not telling their users or developers.

This happens less with Windows because the Master file table or MFT is well documented with Windows file systems.

Elizabeth @miss_liz
Apr 12, 2024
Does anyone have issues with file extended attributes when copying files from a Mac to the (Synology) NAS?
Generally speaking, the mac extended attributes are copied across fine for me, except that occasionally files are left after the copy with the “com.apple.FinderInfo” attribute.
When this happens, the file on the NAS is greyed out from Mac Finder, and inaccessible (you get a permission error).

1 Like

Thank you for the explanation.

Yesterday after work hours, I decided to clean my NAS settings… even if one last time. Naturally, it restored my local folder… but now it’s going to spend several day indexing my folders… at least I did this one last time.

It should give me time to reorganize myself again. I still thing that these NAS was a good purchase… but I need to think of a second option. :-/

Thank you for all the informations that you’ve sharing with me.

They issued a new firmware 9.6.0-111 My Cloud and it was implemented automatically on my device and now i can not long into mycouldhome drive locally on my local netwrok
so, anyone faced such issue after that 9.6.0-111 release which was released on 05/21/2024?

Exactly a week ago I choose to perform a clean settings. This was before my drive got the 9.6.0.-111 firmware update. It’s beed indexing for over a week now… but at least I recovered access locally.

As for the update itself… it took almost a week until my drive automatically updated. So far, everything’s been working smoothly.

1 Like

You seem to be the first to report this.

Have you tried to log into the webapp (browser) and try to ‘Enable Local Access’ again? or at least check if local access is already enabled.
Reboot the the My Cloud Home may be another option, from the webapp.

If these options failed, you may have to do ‘Clear Device Settings’ as others have done.

I raised an incident 240523-004025 for my issue and waiting for their feedback.
release date for the new firmware version 9.6.0-111 is 05-21-2024.

I already tried to log into the webapp (browser).

  • I can see that connection type is already “Local”.
  • When I click on “MANAGE DEVICE” and then click on “CONTINUE” a new tab open with the following message on it “This site can’t be reached xxx.xxx.x.xx refused to connect.”

I also already clicked “REBOOT DEVICE” and waited for the reboot process to complete but still facing same issue after that.

Hi,
After NAS reset everything is now working fine.
I hope will be the same also for you.
By

1 Like

Hello.

Indeed, ever since the most current update was installed, i was able to recover my local access.

Let’s see if it’s forever or if the problem will return. Thanks for letting us know Paolo.