Firmware 7.9.2-100/103 (8/5/2020)

New firmware out apparently with very surprising release notes.

I have never been updated to 7.9.0 since its mid July release. So virtually 2 months without any update. Still no roadmap.

(Haven’t heard of the beta program to confirm whether MCH was concerned).

Firmware 7.9.2-100 (8/5/2020)

  • Bug fixes and performance enhancements
1 Like

Has anyone been updated?

My WD still on 7.8.0-112



1 Like

They seem unsure about all this…

They changed the dates and added a new build (103) for 7.9.2.

I have yet to receive the update.

Firmware 7.9.2-103 (8/5/2020)

  • Bug fixes and performance enhancements

Firmware 7.9.2-100 (8/3/2020)

  • Bug fixes and performance enhancements

Firmware 7.9.0-129 (7/14/2020)

  • Fixed an issue that could cause high memory consumption when resizing photos
  • Bug fixes and performance enhancements
1 Like

I looked just now, and I have 7.9.2-103 installed. I don’t know when that updated, but I manually rebooted it the other day to see if it would update.

1 Like

Maybe they had stability issues with the former released and they are just now making it generally available.

It’s weird that they felt obliged to change the release dates, whatsoever.

same as me

1 Like

Bei mir das gleiche, immer noch Firmware 7.8.0-112 (27.05.2020)

1 Like

Adnotacja 2020-08-20 194222
old firmware :frowning:

1 Like

Good morning, I think you had problems for auto updating My cloud Home firmware. Did you get the answer to force the firmeware update. I just bought my new My Cloud Home and it come with 2017 firmware! Nothing works today with this version.
Thank for your help.

1 Like

There is no way to force auto update as far as I know.

How long has your MCH been online? The knowledge base states that it sometimes wait 24h before auto updating.

We are many being disappointed and disappointed again and again about this product. Maybe it is still time to return it?

What’s your firmware version?


The MCH has been onlina around 20 hours. Any recomendation?

Wow. That’s the initial release…

Did you buy it new? Many of us would recommend going for a proper NAS.

Here (, they say that it may take up to 24h to proceed.

And recently, WD support wrote me that:

Please kindly note that the OTA firmware update cannot occur when the My Cloud Home device has a slow internet connection. In fact, the firmware update process has a 5-minute timeout; if the estimated 250 MB firmware image is not downloaded within the 5-minute timeout, the process will be aborted.

So maybe wait 4 more hours.
If it does not work I guess you can try to restart it or hard reset it.

My connection is fast enough. I will wait 24h, reboot, and if it does not work I will return it. Any other NAS recoemnded ?

I regret not buying a Synology. Because it is more capable. I used to own one.
But I guess other brand are good too.
Do you have a Windows or a macOS computer?

Windows. I am going to wait a couple of days… I have time yet to return it.

Did it update?

Mine is still stuck at 7.8.0-112.

Similar problem: startet Firmware-update on Aug 24th (fast internet connection, downoad was finished within 1 minute), message popoed up “mycloud will now reboot” - up to now system is “rebooting” - mycloud home is still not accessable from my MacBook . . . nor from the fritzbox admin console.
I guess only power switch off and on might help - any suggestions?
Thanks in advance :slightly_smiling_face: