My Cloud EX2 Ultra and Time Machine Verification Issue

I’ve been backing up my MacBook Pros to Time Capsules/AirPort Expresses ever since I’ve had them (a super long time). This time, however, when my AirPort Express died, I discovered that Apple no longer made them. I ended up with a 2 TB My Cloud EX2 Ultra.

I think I’ve set it up correctly. I’ve gone through a number of the threads here and made sure that I checked all the boxes.

For reference:

  • The MacBook Pro that I’m on is running OS X 10.15.7 (Catalina); it’s an old machine (mid-2012)
  • When I log into the My Cloud dashboard, it tells me that:
    • There is 1.25 TB free (plenty of space)
    • The disks are healthy
    • I’m running firmware version 5.20.113
    • There’s no cloud access (it’s disabled)
    • The TimeMachineBackup has 100% of the share
    • The RAID is set to mode 1 (there are two 2-TB disks)
    • The “Mac Backups” selector is set to “On”
    • The SMB protocol is set to “SMB 2, SMB 3” (default)

I am sure to log out of the dashboard when I’m done with it.

Here’s the problem: I backup my laptop using Time Machine. The first backup takes a long time (obviously); it’s done over an ethernet connection. The next few (not sure how many) backups complete fine. Then, what seems like the next day, I get the following error:

“Time Machine completed a verification of your backups on “MyCloudEX2Ultra.local”. To improve reliability, Time Machine must create a new backup for you.”

At which point, I have to either click “Start New Backup” (which starts everything over again) or “Back Up Later” (which stops all backups until I create a new complete/base backup).

This has happened three or four times now and is very frustrating. Is there a solution to this issue?

1 Like

Sounds surprising to me.
I am running TM on my EX2 Ultra and it’s been solid with 4 MacBooks either on Monterey, Big Sur or Catalina. All backups are encrypted.

Were you already using Time Machine over SMB beforehand?
Have you tried to check you startup disk? (Restart with recovery and check disk?)

I’ve been using Time Machine since it came out. I’m not sure if I was using SMB before or not; whatever the AirPort Express used to do its magic was how I did it.

I’ve checked my startup disk - no problems (disk check and virus scan).

The really odd part to me is the timing. The first backup finishes fine and Time Machine behaves normally. The next few backups do the same thing. It’s 1-2 days later when this problem appears, but the problem is consistent and very repeatable. I thought this might be a setup issue, but I can’t find anything wrong.

I double-checked to make sure that I was logging into the EX2 Ultra with “admin” and the password… That’s not the issue.


Regarding SMB I was referring to the use of the EX2 Ultra not the AirPort Express.

Just to make sure (you were pretty detailed, thanks), are you using the TimeMachineBackup share? (The default setting is to use it as guest when selecting the TM share)

  • Are your backups encrypted? (Do you tick the box when selecting the backup share?)
  • Is the startup disk SSD or a spinning hard drive? HFS+ or APFS?
  • You said you were using an antivirus, which one? is the antivirus always running? Do you know if it’s scanning the share while backing up?

This is the first non-Apple NAS I’ve used.

My backups are not encrypted.

Yes, I’m using the TimeMachineBackup share, but when Time Machine goes to that disk, it logs in as “admin” with the correct password (and not “guest”).

MY startup disk is SSD, APFS.

The anti-virus program that I’m using is “TotalAV,” but I’ve turned it off until I get this sorted (just to rule it out as a culprit).

I don’t know if it could make your backup unclean, but WD (init @WDStaff ?) recommends logging as guest to the TimeMachineBackup share.

As an admin you certainly have access to all shares… but maybe give it a try.

I could try it once this backup finishes (460/750 GB done). Do I need to set up guest access in the WD dashboard? Does guest have a password (if I don’t set it up)?

I don’t understand how having Time Machine mount the disk as guest would have any positive effect that logging in as admin would not.

I agree but give it a try?
Make sure the share is public, so no password.

The first (complete) backup was completed using admin and the correct password. The second (first incremental) backup was completed using guest and no password. Assuming nothing has changed, it’s just a matter of time before I get the same error message.

1 Like

Like clockwork - same error. Again.


Sorry to hear about that. Did you open a case with WD support? Would be good to hear @WDStaff at some point.

I opened the case on Sunday; I have heard nothing. If I do, I’ll post it here.

1 Like

Any word? this has plagued me for years, but sometimes I’ll get months before it craps out

I’m afraid I never got anything useful from WD; their best contribution was on the level of “Is it plugged in?” I’m not sure the people on the other end were capable of reading.

In the end, I made sure that (a) the computer NEVER goes to sleep and (b) sharing was set correctly. It seems fine at this point. If the computer goes to sleep in the middle of a backup, that’s apparently “bad,” as is going to sleep before a backup - the WD does not wake the computer for access.

Even if using just an external USB disk -

Apple recommends having 2 to 3 times the space on the backup disk as the data being backed up .

When the TM program has to delete files to make more room things get even slower.