My Cloud EX2 keeps dropping out

My EX2 drops out pretty much every day or 2nd day. I can’t access it from any device on my network (times out without connecting). I have to turn it off/on to fix. I have tried unplugging the ethernet, rebooting the router but this makes no difference so it seems to be an issue with the unit itself.

Things I have tried:
Daily shutdown schedule
Static IP
4 second reset

Anybody have any thoughts??

Hi Doubar,

I would recommend you to check the Firmware of My Cloud EX2 device whether it has latest firmware installed on it or not.

You can try 40 second reset on the My Cloud device in order to solve this issue. Refer the link given below for the same.

You can try connecting your My Cloud device directly with your comoputer via ethernet cable to find out whether the issue is with the device or the network.

Hi. Thanks for that. Just an update. I tried plugging it into my computer and that didn’t make a difference, so I def don’t think it’s network related. Did a 40 second reboot last night. It’s running fine at the moment, but it normally runs well for a couple of days before dropping out so we’ll see.

Ok. 3 days later and no issues so far. Looks like the 40 sec restart did the trick.

Hi Brandon

Since I have done the 40 second reset, I am unable to access my MyCloud via the web or my Mac app. It tells me that the certificate is invalid. I’ll send through some screenshots. Any ideas??

21%20pm

None of these actions work…

I have tried the 40 reset
I have the latest firmware
The My Cloud Ultra is connected to the same router as the computer, (iMac running 10.14.1)
It has a 4Tb USB disk connected.

I map 2 shares to it but they drop after about 5 min

I have tried not using the USB disk but no joy!

It used to be OK but started giving trouble about 2 weeks ago.
I have replaced the router and cables

Any suggestions

The 40 sec reset worked for me, apart from the certificate issue, for at least a week. (I am now referring to that week as “the golden age”).

It has since died completely. The raid degraded, followed by double disk failure. Looks like all my data has gone. I’m waiting to hear back from the warranty team to see what I can do about it. But I would definitely suggest backing up your data. Don’t rely on WD as a safe storage device.