My Cloud Drive not accessible

Hey all,

I’ve been troubleshooting this to no avail - I have a WD My Cloud drive connected to my network and am now receiving the following error “\MYCLOUDNAME is not accessible.  You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.  The specified network name is no longer available”.

To give background:

  • I’ve had this drive up and working properly for months now, connected via a switch to the local network and all computers were able to access the drive.  The switch is also connected to a wireless router, which in turn is connected to the a modem for internet.

  • I had some issues with the switch and router and replaced those today, but was able to access the drive fine for about an hour, then the error

  • I am able to access the drive via the WD My Cloud Dashboard and also the WD My Cloud Desktop app (via any computer on the network) - open folders, files, see all the shares etc.  All settings have not changed.

  • I’ve tried disconnecting, remapping network drive, re-entering passwords, etc.

  • I’ve tried one post the said to turn off all network sharing, delete network adapters, reinstall, turn sharing on, and viola.  But this did not work.   (click here for this thread)

  • I’ve messed with the firewall, on and off.

  • I can see all the other computers and devices and access them fine via windows explorer and can even see the My Cloud Drive fine but when I try to browse it, click on the old short cut links that use to point to it, I get the error above.

I’m confused on how I can access it via the dashboard and desktop app but can’t browse via windows, which is what I need to have this function properly.

Any thoughts or help is much appreciated.

If you can access the Dashboard, then what happens when try to access/map the drive using its IP address?

Regards,

I will get the same error that its in accessible. I’ve tried disconnecting all my networked drives, re-using different credentials for the log in, but still won’t let me map the drive or explore to it via windows.

I have the same problem, any solution?
I’ve tried downloading the wd discovery to map the folders in my system but I get the same error over and over again. A pop up appears with the 192.1.xxx requiring a login and password. I’ve tried to input my wd user and password/or my computer user name and password and I get the same error displayed above:
"\MYCLOUDNAME is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Under dashboard/users do you have full access selected? Just a thought

Have you tried messing with the credential manager? I had a similar problem, went to Control Panel, User Accounts, manage Credentials. There I deleted all (yes, also the generic one from MS Live), then added the user name and password for my cloud. Make sure the user name contains the mycloud name in caps, as in MYCLOUD_NAME\my_user_name.

You probably need to reboot your computer to flush out all conections and credentials from previous attempts. Let Windows discover the network. If it sees the mycloud in Explorer under Network, open it. Let me know where exactly you are getting the error message.

1 Like

Yes, full access. Thanks

When pop up prompts requiring user and pass I write MYCLOUD_WDMyCloud\my_username and the password that I use to log in at the mycloud webpage.
WDMyCloud is the device name in my device profile (I see it in my dashboard)
My_username I use is the one I see in the username under the users tab and user profile in my Dashboard. Password is OFF in the user profile. Full access is granted.
When going to control panel and manage credentials in my windows vista OS, I delete all users, the box is empty now.
When I try to log in to MYCLOUD in windows explore, the error that shows is, log in incorrect. The user name and password may be incorrect.
One thing, when Public Access is ON in Shares/folder/share profile, I can access my folder and move files, change it to OFF and requires log in and password, and the whole problem described above starts.

Ok, under the user tab and user profile in my dashboard, I changed the password to ON, put a pass and now, I can log in using windows explorer by using the username and password.

Thanks

I have had the same issue. I clicked on “map network drive” and added the IP address as a web address i wanted to “map”. It worked and the cloud drive shows up in file manager. I hope this works for you.

This solved it for me (after a year and numerous posts to WD support)

https://youtu.be/iWZIe-5TvbA

:smileyvery-happy: JOY!

After trying dozens of potential fixes; reverting to SMB1 in Network Settings solved it for me (and others). The clue came from CIFS authentication errors in the system logs (Settings>Utilities).