My Cloud Data blocked

Hello, I have a WD My Cloud. It went missing from my network. To make this story shorter I took the drive from it’s enclosure
and connected it to my Windows 10 laptop via SATA/USB adapter. I bought Paragon ExtFS so I could read and recover my data. It seemed to be working. I drilled down through the folders of the drive. When I finally got to the folders that contained my data I got an error message that said “access denied”.
What am I missing?

Before you removed the My Cloud hard drive from the enclosure what color was the front LED? Did you try a 40 second reset? Did you make any network changes (line new router, new computer, new firewall on computer) before the My Cloud went missing?

It’s possible the Share you are trying to access was set to Private through the My Cloud Dashboard. As a test you could use a Linux boot disc like one from Ubuntu to boot your PC to access the My Cloud hard drive, which uses Linux, and see if you can gain full access to the drive contents that way.

Thanks for the reply. Everything was the same as usual nothing new. Blue light went to white solid with no sign of activity. Could not reach the unit by any means. I tried all the usual things like 4 sec reset and 40 second reset. I did install Ubuntu and got the same result as with the Paragon ExtFS program, access denied. Before it went down I had it setup with username and password but I have no way to or options to enter them.

Get the drive back to MyCloud unit and leave it on white light going. It may be doing disk check or something. This happened to me after power outage during storm, after few hours white led changed to blue and everything is still working to this moment (I had about 1,5TB of data on the drive).

I travel alot so I let it go for weeks and nothing.

When you had the hard drive connected to the PC did you by chance check how much free space was on the drive? Perhaps (just guessing here) that the drive might be stuck spinning way if there isn’t any free space left.

What is the single bay/single drive My Cloud model (first gen v4.x or second gen v2.x) do you have?
Has anything else changed on your local network recently, like new ISP provider, change in network equipment?

Can you access the router’s administration page to see what IP address (if any) the router is handing out to the My Cloud or which was reserved for the My Cloud?

Obvious other troubleshooting steps to test (if you haven’t already), connect the My Cloud direct to a computer’s networking port and see if it boots up to a front blue LED. Try connecting the My Cloud to a different network port on the router. Try using a different networking cable between the My Cloud and the router.

Have you tried accessing the My Cloud (in a web browser) using the My Cloud’s IP address (while connected to the same local network)?

If using AT&T Uverse, or one of the routers mentioned in the following WD Support document then try using a switch between the My Cloud and the router.

1 Like