My Cloud drive lost network connection

My 4Tb WD My Cloud drive appears to have lost its network connection.

I have got it connected to my Router via ethernet cable, but the My Cloud drive just has an orange flashing light.

When I go into Network on my PC, My Cloud no longer appears there, also the WD My Cloud Dashboard just says The web address you entered could not be found.

Is there anything I can do to rectify this situation?

I have tried rebooting the My Cloud drive several times and I have rebooted my PC too.

Also the My Cloud app on my iPhone is no longer connecting.

It looks as if my network configuration on my WD My Cloud has got corupted?

I have already tried doing a Reset by holding the reset button in for 4 seconds, I have also tried a System Restore by holding the reset button in for 40 seconds.  After doing this the flashing orange light turns solid light blue for about 1 minute the goes back to flashing orange again.

Any advice would be appreciated.

Have you tried rebooting your router as well? be sure cables are properly attached etc?

1 Like

This seems the yellow blinking bug of not been able to reset to default values after messing with manual assigned ip/dns. 


This  bug  seems  to be fixed in the today new firmware but if you own a device with a firmware different than very last one you will have only 2 option to recover a working device:

  • RMA wyou will receive a refund if on covered period for or a working device without your data and normally with a refurbished hdd (normal practice on the business) 

  • Void the warranty fixing it by opening and writing the os image on raid parttition this way you stay with your device working and your data. 

I have a thread about recovering this nasty yellow blinking bug. 

Your device… Your decision

This issue has happened to me two days in a row now as well.  CIFS mounts in windows go down, NFS mounts from Linux are down and device not pinging at all.  Ping to local net router and other subnet hosts are fine.


I have similar issue with my cloiud 3TB

I bought it 3 days ago and during the last couple of nights i copied lots of data from my PC to the my cloud using cifs \wdmycloud

In the morning i experience the same issue:

The drive no longer appears in my network, the share doesn’t exist, when i ping the drive i receive “destination host unreachable”.

The led is blue.

I have to restart the drive by taking out its power source.

After that everything goes back to normal, mount appears, ping is replying.

I have the latest firmware installed. 

Any ideas ?


seems I had the same problem with myCloud (2TB, Firmware is on the latest release: v03.04.01-230)

After running 1-2 days with no problems, it seems to “disappear” from the network:

Ui ist not reachable, shares are not working, no ping on IP address…

The list of devices, shown on my router contains the myCloud entry as “not present”.

The only action, that helped: unplug the power supply for a few seconds.

After reboot, everything is back to normal.

Also this seems to be the same problem here

So my solution for now is to force a reboot every night via crontab.

If someone finds a better solution, pl let me know.

Just purchased My Cloud 2Tb unit yesteday.  Have been knocked off the network 3 times while trying to upload 100Gb of media files.  Unit freezes up with steady blue light.  Reset button doesn’t respond with either 10 or 40 second depression.  Unplugging will reawaken the unit once it’s powered up and rebooted.  Problem seems to happen when my screen saver comes on, but I don’t think that this is the problem, since my PC doesn’t enter sleep mode and other network devices are still connected.

Tech support seems completely surprised by this this behavior, but this forum shows otherwise.  I’ll try rebooting my router and installing the latest firmware.  If the same behavior persists,  I’ll be returning this product to my point of purchase.

The firmware update and/or the router restart seems to have remedied my situation.  Cloud device hasn’t seen a lockup in the last 24 hours.  Followup up call this morning from Jon at WD to check my settings was welcomed.

The My Cloud UI intermittanly causes Windows Explorer to restart upon exiting the UI, but that hasn’t been a big problem.  If anyone has seen this and knows how to fix it I’d appreciate hearing from them.

The private messages from other users have been informative and eye opening, but I’d prefer to keep the flow of information in the open forum so more people can gain tribal knowlege.



I stopped having problems when i assigned a static ip adress to my device