My Cloud 4T no longer recognized - need data back


I recently purchased the MYCLOUD 4 Terabyte to automatically backup network laptops.  After few months of backing up thousands of pictures and data, the MyCloud was no longer recognized by the computers.  I called WD support who concluded that the device was not working and for me to send it back in exchange for new one.  In meantime, all that data is still on the drive and I can’t get to it.  So I purchased a BlacX hard drive dock to read the MyCloud hard drive directly.  I was hoping to access the data and somehow transfer it to the new Mycloud (which I was able to get before I return the old one).  However, when I put the hard drive into the dock, my computer recognized several partitions seemingly showing 0 bytes available and 0 bytes used, except for one partition which showed a Computer Panel screen with Windows 7 details.  Also litte window pop-ups showed up for each partition stating I could not use it until I formated - which I chose “no”.  I’m now stuck.  Can anyone help?  Thanks.

if you have opened the unit to get the hard drive then you’ve voided your warranty and wd won’t replace it.

To get the data off you need to mount the drive in Linux. It should then show all your data in one large ext4 partition.

Thanks for giving me some light on this, Wormvortex.  I know virtually nothing about Linux or back room shop talk.    So I went onto the web to look at some tutorials.  I am picking up that I need to download this software (I run Windows 7 on my laptop).  Assuming I’m correct, can you suggest which version to get (I see there are a few diffterent types) and what site to get it at.  In the past, I have gone to CNET for free downloads.  Is there something like that for Linux? Thanks… 


you need a clean PC with SATA drive capability (or your USB-SATA  dock device).

You need to build a Linux Debian image on that PC from their latest dirtibution ( ) and then power down.  Plug your WD HDD in to the SATA ports, boot up and creat a mount point (mkdir /mnt/tmp)

Use Gparted or fdisk to identify what your corrupted WD drive assigned letter is (would be something like /dev/sdb or suchlike…the “b” could be any letter).  You can identify the HDD with your Debian PC image versus your WD HDD by size most likely.

Mount the WD drive under your new filesystem

mount -t ext4 /dev/sda4 /mnt/tmp            this tells your Debian PC to mount it as type ext4 filesystem

cd /mnt/tmp                                                 move in to that directory

issue the ls -l command and you’ll see severl diretories including “shares”.  Your data is under there. 

Set up a data transfer from that directory to a new device (you can dd it if you attach another new and working drive for instance, else ftp the data off).

I know the above is fairly technical to a linux noob, but that’s what’s required I’m afraid.  Also, don’t forget to zero the disk before you return to protect your data from being recovered by a 3rd party.

Good luck and hope this nudges u in the right direction.


I am confused if you backed up network laptops data and pictures surely you still have the data, why do you need to get it off the broken MY Cloud?

Thanks, Rootfourme.  From what you say, I now have two choices:  spending /weeks learning this stuff or bringing in an expert.  I would opt for the latter but I’m worried about exposing proprietary data to wandering eyes.  Think having Geek Squad or something similar out to my location would be advisable, and do you know if this would be in their area of competence/expertise?


if the backup solution only retains n-2 or n-3, it is conceivable that legacy versions of documents could have been lost?

if old versions were required for audit or financial regulation, the backup might be important (although of course, a redundant & resilient backup solution should have been used!).

Hi Daveyk15.  None of my laptops recognize the old WD MyCloud device which has the data - it’s like it doesn’t exist.  WD support concluded the drive can’t be accessed as normal, so that’s why I’m trying to access the drive directly via a docking station, but I now find it’s much more complicated than just docking and reading - as you can see by the other technical responses to my original post.  I did get a new WD MyCloud out of the box which I intended to be the destination for the data from the old MyCloud assuming I can figure out how to transfer it.

Well, not sure of your location, but you must have a nerd friend (everyone does) who could asist?  I am of course being hopeful here.  it wouldn’t take you weeks to learn…probably a day or two tinkering and you’ll be staring at your data if not already recovering.   After all, you are not really needing to learn Linux…you just need to understand half dozen commands after which I suspect you’ll blow the Linux PC away and rebuild  (unless you fall in love with with the OS or grow a desire to tinker & learn it of course).

It’s not difficult, especially with Google as your friend.  

If you do buy-in resource, you could always insist on being present to oversee what they’re doing…or even better have them onsite at yours to get the ftp/dd up and running…(ftp is the simplest option btw and could connect any device to your mounted filesystem).  

Hello Routfourme, antother question… How long will all this take for someone who knows what they’re doing.  FYI, there’s about 400 Gig of data to transfer from the old MyCloud to the new MyCloud?

so how fast is your LAN?  if you have gigabit then expect fast data transfer times…maybe 60-70Mb/sec.  if you don’t have gigbit, then anywhere from 5 to 10Mb a second.  The rest is simple maths (although lots of small files are cumulativley slower than a few large ones, and encrypted ones may also behave strangely…).

I would expect a 400Gig to be 20 to 24 hours on a slow network using Filezilla ftp with 4 or 5 parallel streams running between source & destination.   Network contention and speed is your bottleneck.

1 day to build, mount and view data (2-3 hours for someone with experience) and a day or so of non-human interaction to complete data transfer to your new destination.

I’m thinking of taking on this task myself… at least for now with, as you say, Google as my friend.  Before I do, I want to make sure I have everything I need from a hardward standpoint.  So far I have a BlacX docking station (which has both a SATA and USB 2 port) and is currently holding the old MyCloud hard drive, my laptop with NO SATA port but 4 USB ports and an ethernet port, and a thumbdrive.  What else do I need besides… another computer, port adapters (you mention SATA, but my computer doesn’t have that port.  Obviously, I wouldn’t want to have to buy another computer.  Thanks…

Correction to my post above… I do have SATA port

Follow up to last post, Rootfoumre, …WIll thumb drive suffice for the “clean computer” you say is needed? 

yes, a thumb drive will suffice for a slim trim linux distro.  or a partition on an existing drive, or a blank legacy HDD laying around whihc can be plugged in to the motherboard.  Anything really…but a linux distro it needs to be.  I mentioned Debian as it is my favoured and the WD-used platform …but anything would suffice.  All you want is to boot in to a kernel, detect WD drive letter and mount the filesystem, then ftp in (or Widows share or whatever) to transfer off.

So you do have a Sata port.  Good.  But the USB-SATA dock would suffice too.  

Rootfourme, if you’re still monitoring, I have successfully created the Linux Debian image (I used Ubuntu download) on a flashdrive and have been able to boot my laptop with it.  I have the old MyCloud device mounted in the BlacX docking station and attached to the laptop via a SATA cable.  When in Ubuntu, I was able to see data on the MyCloud drive. I was also able to identify the drives associated with the old device which are G: through L: (total of six drives).   I also have the new MyCloud device installed on my laptop and it is directly connected with an ethernet cable.  So, at this point, I think I’m half way through your instructions.  But I don’t understand the acronyms and directions at and beyond the point where you state “Mount the WD drive under your new file system”.  Can you spoon feed that to me… Again, I know nothing about this stuff but I can follow instructions… Thanks.

If anyone who is following this discussion can add anything to guide me forward I’d appreciate.
I can see the files under shares on the old mycloud with Linux Debian Ubuntu. It gives me the option to “copy to”. I want to copy to the new mycloud which I have hooked up to the laptop with an Ethernet cable. My laptop recognizes the new mycloud under the"network" part in the control panel, but I can’t locate the new mycloud from Ubuntu when it asks me to select copy destination. Two questions: am I on the right track using the “copy to” option ( is it as simple as that?) and if I’m on the right track how can Ubuntu locate the new my cloud on the other side of the laptop - it’s connected with an Ethernet cable?

Evening, just passed by and seen your message.

OK, so you can see your Linux WD filesystem.  As well as the filesystem you have used to boot into a linux Distro  (You talked of both Ubutnu and Debian…they are discretely different distros philosophically, although Ubuntu is a commercial variant of Debian…so under the covers very very very similar…I’m drifting off the point…)

So you have issued a df -h to see the mounted filesystem allocations in a human friendly format  (what the -h flag means).

You will see the filesystem of your Linux OS.   you need to create a new temp filesystem to mount the WD filesystem with your data into…  issue from command line mkdir /mnt/wdcloud     that means make a directory from the root level of the OS called /mnt(mount)/wdcloud(a unique name).      That is now an unmounted but created filesystem.  It is present but empty.  What you now need to do is to identify the area on the WD CLoud where your data is and mount that under your new filesystem /mnt/wdcloud.   Hope I’m making sense…

issue  blkid which tells your your attached  HDD UIDs and their letter assignation.  Hopefully…

Also issue _ fsdisk -l _  which again should give you a hint to what your HDD letter assignation is.  

You are looking for something like   /dev/sda   or /dev/sdb  or /dev/hba…it will be something like that (although it may differ on a thumbdrive…I’ve never booted from them so dunno).

The fsdisk should also be feeding you details on exactly what partitions on e.g. /dev/sdb you need.   It should report something like (below for a 750Gb HDD):  

Device     Boot  Start        End    Sectors   Size Id Type

/dev/sda1  *      2048     499711     497664   243M 83 Linux

/dev/sda2       501758 1465147391 1464645634 698.4G  5 Extended

/dev/sda5       501760 1465147391 1464645632 698.4G 8e Linux LVM

_ You _ will see a boot sector  (/dev/sdb1?), a mirrored OS partition (/dev/sdb2 and /dev/sdb3?), and then an unmirrored data partition.  (/dev/sdb4?).   You can tell which is which by the size of the partition.  It’ll be bleeding obvious which is the data partiton.  My gut feeling is you will be looking a /dev/sdb4 but happy toi be proven wrong.

Now mount that data partion on the WD Cloud to your newly created filesystem mount point. 

_ mount -r -t ext4 /dev/sdb4 /mnt/wdcloud _        This mounts as read only, in Linux filesystem type ext4 your data partition in the created filesystem mountpoint.    ***ensure you do the read only so you don’t write to the partiton and lose data***  ***change the /dev/sdb4 to match whatever text string your data partition is called***

Issue _ df -h _ to see the WD Cloud partition mounted and the filesystem size and both Gb & % free space

_ cd /mnt/wdcloud _     change directory into your mountpoint.

_ ls -l _  to view the files.   use _ cd  /mnt/wdcloud/xxxxx   _to navigate around the directories where xxxx relates to names of directories in your data.

You can now use an ftp program, or drag and drop or whatever mechanism you favour (hint hint  ftp it), to copy data off the moutned read-only filesystem to your new and connected external HDD.

I said right at the start that you don’t need to learn linux.  You just need to issue a few commands, identify the data partition name and pull data off.  The above achieves that for you.  Once data transfer is complete, be nice to the system and your data…  

Open a second terminal window.

On the first terminal window issue _ df -h _   to check the filesystem as it was at the start, 

_ cd /mnt/wdcloud _

_ rm -r * _    recursively remove all files and directories from this mount point.  Will take a little time.  i.e. delete your data

_ cat /dev/zero >nosuchfile; rm nosuchfile _      This now fills your freshly deleted free space (which still has readable data upon it) with zeros.  Will take maybe 4 hours per Tb.   It then fills the filesystem by catenating a zero written to every possible byte into a new file called “nosuchfile”.    That file grows and grows as zeros are appended to it.   The filesystem will then fill up and hit 100% allocated physical space and that proces will keel over.  Then the system sees your second command and removes that file called “nosuchfile”.  

The above will lock up the first terminal window interface during command processing.  Issue in the second terminal window regular _ df -h _ to see the filesystem gradually filling and filling.

Once it hits 100% and then deletes the “nosuchfile” file…do it again to write zeros over deleted zeros.  

_ cat /dev/zero >nosuchfile; rm nosuchfile  _

So in another 10 - 12 hours for a 4Tb device, you are done.    Be nice…unmount the WD Cloud filesystem and log off.

_ umount /mnt/wd _

_ df -h _ shows the mountpoint is now gone.

_ shutdown now _      does what it says on the tin.

Unplug the HDD and box it up ready for i) return for RMA or ii) use in a PC (just reformat and rebuild coz the disk could be OK…check with a disk surface integrity checker forst of course).  or iii) put a hammer to it.

Depending on your distro, some of the above command &/or flags may sublty differ, but it’s good for Debian based Linux versions.   You’ll have to google the subtle changes if any are required.

My disclaimer…the above does and should work…if you do it correctly.  If you hit a problem, then perhaps mount without the read only flag.  It also depends on the physical condition of your disk.  If that is shagged, then I’ve wasted a lot of time writing this out.     End of.   

Oh… and then you can buy me a beer.

Good luck R4M

ahhhh…think I was typing furiously when you asked the wider world for help.   Our posts have kinda passed each other in the ether.  Hope my last positing gets you where you need to be.  


4rm, thanks for that- wasn’t sure when you were coming back. In meantime, I tried finding a command line on the Ubuntu .
Not sure it has one-seems menu driven. For that reason I’m going to back track and find the Debian you mentioned and then try the commands. I’ll try searching some sites and create something similar to the Ubuntu setup. Thanks.