My Book Live WD2Go WebDav? Issue - FAT

Recently purchased a My Book Live 3TB Device…

Working fine on home network - laptop, ps3, wdtv live media player etc…

Works great on iphone and and android phones aswell as google nexus 7 tablet, both on the home network and remotely using the wd2go app.

Here is the problem - When I am in work, i log in fine to wd2go, i hit ‘open in explorer’… I am able to see the files, but i am unable to play them or copy them.  I notice that the device is mapped as a FAT device and is displaying the storage capacity of my local C:/…

I have read on here that loads of people have similar issues and it seems to be a webdav issue, maybe?,  but i just cannot seem to find a solid solution to it… Can anyone help?

It’s only an issue for people NOT using WD 2go.

When you’re using WD 2go, all the things you describe are “normal.”

Copy can LOOK like it’s not working, because Windows Explorer, when you Right-Click or select a file, starts examining the file immediately looking at metadata, thumbnails, etc.   This is a “feature” of explorer, because explorer expects all of the files to be local, where performance is VERY good.   But when it’s actually connected via the internet, the performance isn’t good enough to do all that.

But it WILL work, if you give it time to do its thing.   If your internet speeds are slow, it can take a VERY long time.

Copying via Command Line works a lot faster, in many cases, as does using other methods OTHER than Windows Explorer.

Hi Thanks for the reply.

I am in work now.  I have connected to my Movies Share via WD2go and i can view all of my movies.

When i go to Copy one, to the local C:  (using TeraCopy), i get the following status as soon as it tries to copy the file.

Open Error - A device attached to the system is not functioning…

When i try copy via CMD - i get “the system cannot find the file specified.”

Still all fine on the home network though and the modem is 100MB line.

Need to get this external problem fixed.  Drive mapped as a FAT drive and reporting local drive capacity.

pajjo wrote:

Drive mapped as a FAT drive and reporting local drive capacity.

Again, that’s normal.   Network drives are neither FAT nor NTFS.   They’re “Network.”   But Microsoft doesn’t indicate that, it just indicates FAT for WebDAV and NTFS for anything that’s CIFS.

I’m not sure why you’re getting those errors.  I’m having no problems wiht mine from work…  (Though, I seldom use it because our internet bandwidth usage is monitored and reported…)

Well i dont mind if it is coming up as my C:\ storage and i dont mind that it is Fat instead of NTFS…

I just want to be able to copy from a remote location and watch the movies from a remote location.

Is there a way of accessing the NAS remotely but not going through the WD2go URL, such as ftp or a direct url to your router

such as http:\IP_ADDRESS\Public because when i try this, i actually get prompted with a username and pw box but it will not accept the username and pw that i use with my NAS…  This is driving me mad…

Anyone?

In your EXPLORER window, DISABLE the Preview and Details panes.

Click the ORGANIZE button (Top, Left)

Select LAYOUT

UNCHECK DETAILS

UNCHECK PREVIEW

Why?  All i want to be able to do is access the files remotely… It is a feature of the appliance so why is it so hard for me to do?  Using the WD2go interface will always map it as FAT and this is on 20-30 Windows XP & 7 Machines that i have tried… All Pcs have same end results… Drive will map, files can be viewed but they cannot be accessed or copied and the pc will hang and need a forced reboot…HELP

pajjo wrote:

Why?..HELP

Why?  It’s called “troubleshooting.”

I’m trying.  But if you don’t want to do your part, that’s fine.

Hi Tony

I am using Windows XP so i do not have an organise option but the only panes on show are Name, Size, Type, Date Modified.

I am not sure though why this will help in me been able to download files or Stream files from the WD2go remotely.

I’m sorry – I don’t know what to tell you.

I am at work now, and I just copied a 588 Mbyte movie from my MBL.

The PC sat there “Calculating…” for about 3.5 minutes while it was copying the file to some temporary space, and then about 10 seconds copying it from the temporary space to the destination.  I could tell it was actually copying (even though the status screen did not indicate it) because the Windows Network Monitor graph was showing about 40% utilization of a 100 meg connection.

240 seconds total to copy 588 Mbytes – equates to about 2.4 Mbytes / second transfer, or about 20 megabits/sec.

My internet upload speed is 35-40 megabits per second, so all in all, the transfer was reasonably fast.   I don’t know if my company’s internet QoS policies would have affected it, but we only have a 300 megabit/second internet shared by 15,000 people…

Another update:

I just launched “Big Bang Theory” (approximately 190 Mbytes) into Windows Media Player (simply double-clicked the file…)

It took about 60 seconds before playback began. (But again, the transfer started immediately evidenced by Windows Network Monitor).

Maybe you’re just not being patient enough, or the over-all transfer speed betwen your home and work networks isn’t nearly fast enough.

I am at work here also

Just tried the waiting game… I copied a 250MB file and after 30 secs or so, it started to copy… Then an 800MB file done the same… When i try a 2GB file though (using TeraCopy) rather than Windows Copy, it will not copy and the PC freezes…

I see from going through the forum that anyone who is suffering similar issues are struggling to copy, stream and then having their PC freeze.

Yes, the behavior may be different.

At least in Windows 7, I’m not having a problem with 2GB plus files.

The difference is, as soon as I RIGHT-CLICK the file, the transfer starts, and the window goes “Not responding.”

cap.png

However, I can still tell that Windows is copying the file to local cache:

cap1.png

… a minute later:

The file is definitely growing quickly.

Once it’s cached, it should be fine.

I’ll wait and see.

Ok.  After 13 minutes (!)  the temporary file was created.

I then got the Right-Click menu to work instantly, and COPY/PASTE to my local disk:

cap3.png

Obviously, 16 MegaBYTES per second is not correct.  But that’s the speed of the CACHE to LOCAL copy, so it’s ON DISK already (in the cache.)

And the paste took less than 15 seconds.

Here it is in my local disk now.

Now I just have to wait until the bandwidth police show up!  :smileyvery-happy:

Cheers Tony,

I will test on a W7 PC and see if that sorts it.

Hi Tony

I have tried to copy 2 Batman films (both < 2GB) and they are copying over fine

However, when i try copy a file over 2GB (Blood Diamond - 3.09GB in this case), then i get an error saying can’t read from the source file or disk…

All files under 2GB seem ok now but no luck with over 2GB files

Help appreciated.  If i can get this working with >2gb files, then i will be happy enough with the WD2Go Service and NAS Device.

This is what I think is going on – and it’s a guess.   It’ll take a lot of research to prove it.

*some* parts of windows have no idea what *other* parts of the OS are doing.

This is proven by the fact that the Explorer window will go “Not Responding” when even right-clicking a large file before the Pop-up menu appears.   But it’s obvious that OTHER parts of Windows are still doing things – copying the file to the WebDAV Cache directory (a hidden, protected path in Windows 7.  Not sure how XP does things.)

In your case, what I think may be happening is that the “■■■■■” parts of the OS are timing out – it’s taking too long for the “other” part of the OS to do its thing, like moving the file to the cache directory.

If it takes too long, the OS throws up its hands and gives an error, even though, if it were to wait long enough, it’d work.

Not a bad theory except when copying a file that is over 2GB, you get the error immediately saying cannot read from source file or disk

The thing is, i cannot understand how more people are not giving out about not been able to copy files over 2gb as this seems to be a popular device and one of the key elements of it, is the NAS WD2Go feature…

At least i know know when the PC is hanging, i dont need to force reboot anymore as i know the file is actually copying… I wonder if i have set a setting somewhere on router or my dashboard where i have told the device not to copy a file over 2gb.  I don’t think i did though.

Tony - Are you able to copy files over 2GB?

Ok, this is weird.

I just came across this WD document:

http://support.wdc.com/product/wd2gofaq.asp?lang=en

which says, in part:

Why does WD 2go modify my Windows registry settings?

During connection, the Windows® Registry update increases the file transfer size from your My Book Live to your PC from 50 MB to 2 GB.

2 GB?   Maybe that’s what you’re seeing.

HOWEVER, I just sucessfully copied a 3.6GB ISO File of Clash of the Titans:

It took almost 20 minutes before things “appeared” to move, but then copied very quickly (typical behavior.)

So I wonder why the doc (and you) seem to have a 2GB limit when I do NOT.

Well, I’m using a MyBook Live DUO drive, which recently just had a firmware update.   I wonder if WD has changed this parameter.

Go look in your registry to see what the value says under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters\FileSizeLimitInBytes

Mine is set to 0xFFFFFFFF (4.2GB, approximately.)

Yes it is already set to that value… Another query then would be… What if i wanted to copy a 10GB file?

I guess this device just is not properly set up for remote sharing on windows platforms.

untitled.JPG