My Book Live 3TB unusable - How to recover data?

Hi all!

I have a pretty simple question, and I truly hope the WD community can help me (as the Tech Support gave me false answers!!)

About a year and a half ago, my MBL 3 TB fell from about 6 feet high, right on the ethernet cable. This completely destroyed the ethernet port, rendering the device unusable.

I tried many different ways to recover the data, either through Linux or Windows apps that can apparently read linux drives (like the MBL), but all to no avail.

I have contacted WD’s Tech Support, and I asked whether it would work if I were to purchase the same product, and simple use the hardware of the new one to recover the data of the old one. Tech support said yes it should work. I asked whether I needed the 3 TB or a 1TB could do the trick, I was told it’s all the same hardware, should work.

Bought a MBL 1 TB and got it today. Took it apart, took the hardware and plugged it in the old drive: Nothing! The drive doesn’t even start, and the light is a steady red. If I unplug the hardware into the new 1TB drive, it automatically starts the drive and light goes to blue, then steady green in a matter of seconds.

I am really tired of having to deal with that **bleep**. Plus, I bought a seperare, non-network 3TB drive just to transfer the data from the old drive to this one.

I basically want to know: Is there a way to recover the device’s data ? And if so, how ?

I read here quickly that plugging the drive into another NAS device should work…is that true ? At work we have a Synology rackmount 12-bay NAS (RS2414RP+)…if I were to bring the old 3 TB drive there and plug it in, would I be able to access the data on it and transfer it to another drive ??

Thanks in advance for the help, I’ve been without my music, movies and TV Shows for so long, it’s becoming a real pain in the a$$ :frowning:

You can check with a Data Recovery company.

There’s a list on the link bellow:

Hi John,

Thanks for the reply. I am aware of Data Recovery companies, but for a 3 TB drive, it’s gonna cost me hundreds of dollars, if not at least a grand, and that is unthinkable, considering the drive itself is 100% functional, BUT, WD made it so it can’t be read if not in their own enclosure.

What I’m searching for is to know, either from WD or someone who experiences the same problem, how I can recover the data WITHOUT having to pay an enormous sum of money to a third party company. 


There other post if you search on the forum for this drive that have information in that regard.

WD does not support nor does recommend any sort of method since in most cases the warranty gets voided and drive could be rendered unusable.

At that point, Warranty isn’t a problem, as the drive is way past my warranty.

The only thing I care about right now is recovering the data that’s on the drive.


You mentioned…

“I tried many different ways to recover the data, either through Linux or Windows apps that can apparently read linux drives (like the MBL), but all to no avail.”

and did not work, getting the same hardware and replacing the hard drive will not work as well. Chances are there is an issue within the hard drive, or OS is corrupted. Getting a new NAS and replacing the drive would work when there are issues with the enclosure vs the hard drive.

Not sure what guide you followed, as there are plenty of different ways to achieve the same, but if you followed the unbrick guide such as this one: and could not read the files or mount the drive, there will not be any DIY options.

Also, might be a bit too late now, but for any important data, make sure you always have a backup.