Data recover on a My Book Live 2TB - HELP!


#1

Hi Guys,

Hope among you, out  there, is somebody who can help me recover the data I had on a “TWO MONTH OLD MY BOOK LIVE”.

The story goes like this: I had issues upgrading the Firmware to the last version, I’ve been contacting support for it and got a list of steps to follow. Last step was to reset my NAS from the button behind. As soon as I’ve done this, my NAS could not be seen/found on the network anymore.

In the end, WD Support allowed me to open the casing and recover the data. Attempting to do that under Windows 7 64Bit, the data recovery failed due to the fact that it was asking me to format the partitions to be able to use them. Not really an option for me since I want to recover the data.

Downloaded and installed UBUNTU 64Bit and surprise again, The hard drive cannot be mounted, says something about a “bad block” making the mounting impossible. Running Gparted under Ubuntu, shows clearly that there is data on the partition and that is EXT4 as format, but does not allow any data recovery when you try to do an “Attempt Data Restore” (or something like that, I don’t remember exactly).

The thing is, that the hard drive has also a specific partitioning, this new GPT used to replace the old MBR and its limitations over 2TB.

So, to cut it short, is there anybody who can help/advice me me what I can do to recover the data? I would very much appreciate it.


My Book Live 2TB not accessible. No green light
Lost access to all files
Reset settings to factory
Please help! I just deleted a major group of files on my WD LIVE 6TB DUO (RAID)
MBL showing empty folders [Data Loss ?]
Recover deleted data
Trying to save my data - 4 volumes on disk
My World Book Ed With Blue Ring Raid 0
#2

Try Disk Internals Linux Reader for Windows. People have had great success with this program and it’s free… Lemme know how you make out.
http://www.diskinternals.com/linux-reader/

Another good program is R-Linux. Unlike Diskinternals Linux Reader, you can actually recover deleted files/folders as well
http://www.r-tt.com/free_linux_recovery/Download.shtml


R-Linux very good
#3

Hello Nfodiz,
It worked beautifully. It was exactly what I needed.
Thank you again for your help!


#4

Absolutely genius product.  Saved my A$$ on almost 1TB of personal data!!!  NAS enclosure is ruined due to getting the drive out but who cares…my data is secure due to the DiskInternals app.  Can’t believe it’s free…


#5

You are the Man. Thanks. I really didnt want to drag my old ubuntu box out for this.


#6

do you HAVE to take it apart from this to work???

THANKS

Steve

UK


#7

 please let me know if there is anyway I can recover data without taking the unit to pieces.

thank you so much steve


#8

This is the greatest thing of all time… ALL TIME! I spent a week or so looking for a product that could recover the data off this **bleep** nas. WD drives = good. WD nas=poo. Thanks again.


#9

Guys, after so many successful stories here !!!  me hoping to get data retrived from my My Book Live 3 TB .

I have already tried using Ubunto 32 bit , 64 bit, Backtrack 3 and 5 - they couldn’t mount this 3TB drive.
Also tried DiskInternal Linux Viewer. All i can see is just 4-5 partitions of different sizes on that drive.

I use Windows 7 64 bit computer but i tried on win 7 32 bit and xp etc as well.

Took the 3TB HDD out of box and connected the 3TB drive drive directly into computer on SATA and also tried via USB using a SATA case.

Any advise which way to go now !!!

Thanks in advance…


#10

Thanks guys above!

It worked like a charm!

TGDXB when you see the partitions you can’t copy them into windows you need to push the save button! Your files should be on the biggest partition on the drive!

It’s kind of late but hopefully still helpfull!


#11

Another good program is R-Linux. Unlike Diskinternals Linux Reader, you can actually recover deleted files/folders as well

http://www.r-tt.com/free_linux_recovery/Download.shtml


#12

Hi,

  May I know how to use the Linux Reader to access My Book Live hardisk? I can’t find the hardisk in the Linux Reader windows. Please HELP!!!.

Thanks,
EK


#13

I wanted to reply so that anyone else with this issue can find a great answer if they google it in future.

I had a WD world book, white 500 GB single drive version that for the last couple of days was not powering up properly and would sometimes need the power cable pulled out for a couple of minutes and reseated before it would start.

Had about 70 GB of photos and 50 GB of music, the other 150 GB of files and what-not I did not really care about. I had a copy of the photos folder but it was at least 3 months old…

Before I pulled the disk out I tried on last time to boot it but it was just going tick tick tick - uh oh :( 

In retrospect the disk was fine, it seems the WD logic board in the housing had the problem.

Any way I removed the disk and put into my WIN7 64 bit machine. Windows disk management could see the drive and the 5 partitions, but could not mount the volumns. Tried booting from my trusted PartED Linux distro but it could see the partitions but not mount them either. Here I saw that the major data partition was EXT3 which lead me to searching google for a windows utility to read the drive, and eventually to this forum.

After trying ext2explore, Ext2Fsd and Linux Reader I found the above post about R-Linux.

And thank goodness I did because I did not want to tell the wife that we lost 3 months of photos of the kids and Christmas…

R-Linux was free and great interface and recovered all my required files in a couple of hours and meant I got some sleep last night. So I want to thank nfodiz for posting up the link, and again I wanted to add my recommendation so that others don’t give up hope - R-Linux is da bomb.


#14

Your welcome Reeky :slight_smile: I’m glad you were able to save those priceless memories.


#15

did you get the 3Tb recovered?  i have a problem with mine as well. let me share this WD horror story.

my 3Tb Live Duo was working fine till one day…nothing. the unit would not boot up correctly. blue light going to green, it remained on yellowish.

i called WD and we went through some reset procedures, etc. still nothing. eventually they told me the controller board (no the hard drives) was bad and they would send me out a new unit… so i asked, oh, so i will put my old drives into a new unit? they said no, i couild not do that because if i did, the new unit would reformat (raid mirrored) the drives. so i then asked, well, since the drives appear to be ok, how do i get the data off of them. they then said, oh, i have to use the services of a data recovery house. WHAT???

talk about a BAD BAD design. their box should know the difference between already formatted drives and brand new ones. but let us follow the bouncing ball… so i ask them…   so, i purchase the unit because it has mirrored back up, protecting me from a hard drive loss but if the problem is in the controller i’m screwed??  ya, that is pretty much how it is.  gee, i bet that little detail isn’t in the fine print.

[Deleted]

that said, i guess i’ll try one of the software packages to try to recover the data. i DO have 2 drives…

oh, i got a quote from a data recovery house…one RECOMMENDED by WD… sitting down?  somewhere between $200 and $1000 for my unit. **bleep**?? 

so i guess i need a backup drive to back up the backup drive because THEIR controller went bad.  

sorry WD, that is the last product i purchase from you.


#16

Most of the NAS devices are just external devices to copy/save files to them. They are NOT full backup units.

Backup means you have 2 or more copies of the same files on DIFFERENT devices.

MBL is just a NAS, not a backup. It does come with software/options to do backups (again, it will copy files from
PC to MBL or viceversa).

NAS with 2 or more hard drives are also NOT FULL backup units. They just have hardware redundancy.

See:

http://howto.cnet.com/8301-33088_39-57556308/digital-storage-basics-part-3-backup-vs-redundancy/

And last, if the NAS dies and you have to RMA/return it and it contains sensitive data, you might have to remove the hard drives and wipe them before shipping them. However, what works for me, all sensitive data is stored on a truecrypt file ( http://www.truecrypt.org/)..)

Hardware will die sooner or later, nevertheless, that is the reason 2+ copies at different devices are needed at all times.


#17

Couldn’t have said it better myself.  I am going through the same problem.  My MBL is stuck on the yellow LED.  It looks it may be possible to recover the data based on all the information on these threads, but I seriously doubt if Western Digital will offer to recover the data for me.  I also have a second backup of everything on a USB drive, but I usually only duplicate the NAS once a month or so.  I had higher hopes for the MBL as mine is only 6 months old.  You would think that they could engineer it so that if something went bad on the MBL controller that you could at least put the drives in a new unit and it would know that it does not need to reformat the array!

I will be calling WD tomorrow to see what can be done, but I am not optimistic based on everyone else’s experiences.


#18

ryanb,

Yellow solid or blinking? Either way, make sure network cable is plug in all the way, both ends.

Also, most NAS that come with the hard drives already in them, are either very very hard to open, or warranty is voided if open.

If you want to be able to move/replace your drives as needed, there are plenty of good diskless nas out there.

People, check out this article:

http://www.smallnetbuilder.com/nas/nas-basics/31349-choosing-diskful-vs-diskless-nases


#19

I also had the same problems with my live duo (solid yellow light on the front indicating it is loading the OS).  I called Western Digital support and they told me to return the unit to where I bought it.  I Asked about data recovery and they reccomended a data recovery service I could hire.  After finding this thread I did the folowing and was able to pull my data from one of the RAID1 drives in the NAS:

Opened the NAS

Pulled out drive A

Shut down my desktop PC (Win7 64 bit)

Hooked up the NAS drive to a SATA connector and power

Booted up my PC

Installed R-Linux

Ran R-Linux and found all of my data on the last of several partitions and recovered it to a USB drive

It is too bad there is not an easier solution and really is too bad that we can’t trust the MBL unit a little more.  Remember to backup your NAS frequently!


#20

Thank you.  I had a 3tb livebook that failed. Had some family video on it that i didnt have backed up anywhere else. (bad i know) This did the trick though.  I registered just to thank you since my search found your post.

Thanks again,

Eric