My Book Live 3TB stopped working: no connectivity

My router does not seem to see the device or issue the device an IP address. That pretty much makes it impossible to determine what is going on.

Is there a way to access the device if I bypass the router and plug it into any ethernet port of a computer directly? If so how?

I reset the device and powered it off/on already. 

I already moved almost 1TB of data to the device (that I would like to recover)

Help please! 

Exactly the same issue.  Had connectivity to it by mapping \MYBOOKLIVE\PUBLIC but it seemed flaky.  Had some other network issues in house so I rebooted Comcast modem, updated router (D-Link DIR-655) firmware, rebuilt wi-fi profile, etc.  No sign of it from any iPhone network scanning app, mapping, D-Link admin site.  Oddly the unit spins up, shows link light activity on back of device and on the D-Link router port.  

No idea how to access the unit via the network when either the router won’t give it an IP or it won’t accept one.

Did you have any resolution?

Will call WD next…final step will be to tear drive out of it for direct connect to PC using SATA connection. 

I am in the exact same boat.  Have you figured out hwo to solve the issue?

So far no email response from WD, I am very upset. 

I was a strong supporter of WD but am rethinking my brand loyalty. When a product fails, at least support the customers



Made the decision that the family photos, tax/old email/property/vehicle records and 1TB video collection was worth more than any drive or product use so I tore the case apart and pulled the drive.  Connected the bare drive to an internal SATA cable and browsed in Windows.  Unfortunately Explorer doesn’t see the drive but the BIOS and the Device Manager do…concluded that the OS must be a different file system and Windows can’t see it properly.

Small search…yep, Debian Linux with EXT5 file system…two things I know ZERO about.

Downloaded a free application called DiskInternals Linux Reader for Windows which essentially enables you to see all the folders/files on the drives.  This was a life saver!  Link:

Just install the app and it found my suspect D:/ drive on it’s own.  I muddled around a bit in the /CacheVolume\shares\public and, VOILA, all of my folders in pristine condition.  You then have to set up a Recover Folder (easy) which will slide your folders to the right and insert an empty column titled Files to Recover on the left.  Drag/drop folders on right into Files to Recover column on left and, when done, click the Export Wizard at bottom.  This wizard has about 5-6 steps and generally allows you to select a target folder to send all the scrubbed folders to.  I tested one small folder by sending it to a Recover folder on my desktop and it worked perfectly!  I’m not in the midst of recovering almost 1TB of data into the Recover folder on my W7 machine.  I started the recovery processa about 30 mins ago and it’s about 75% done already.  

Note - be sure you have enough empty space on the recovery disk so you can slide it over.

I am now NEVER going to store any data on a single drive NAS. I will be migrating this data to a Drobo FS (5 drives capable in a RAID stripe) or a Netgear ReadyNAS DUO.  Hopefully a mirrored drive(s) will accomplish a safe copy.  

Trust me, if my wife had to hear from me that I lost our kid’s birth pictures…F me.  

Happy to help anyone with this as I’ve been shi^^ing bricks for three days wondering how I was going to fix this.  I started a Kroll OnTrack scan 3 days ago and it just finished.  Can’t do anything with the folders until you pay…but it’s moot now that the DiskInternals worked.  Whoever wrote that…I owe you one.

Good luck

hi there, i am in exactly the same unfortunate boat.  Our 3TB MyBook just decided to start ignoring us.  The drive still runs, and can even be pinged, but no connectivity and no way to map drive, even by IP.  Called tech support and they are willing to send new one under warranty, but will cost approx $900 by external data recovery service to pull data off.  Figured they will have to crack open anyway, so want to give this a try. 

Your instructions sound easy enough, but I don’t know squat about SATA cables, is there a specific type or model you recommend?  Also, I was concerned that the attached board in casing was somehow encrypting data, you didn’t have any issue pulling off using this software? 

Finally, any advice on how to easily crack this drive open without doing any additional damage?

Any and all info you can provide is so grateful.  We’re in danger of losing hundreds of music albums and thousands of pictures

so its been a long long weekend, but i finally have rescued my 3TB drive.  I tried every possible linux reader i could find, and nothing worked (including diskinternals).  Despite everyone’s recommendations, this utility program is unable to read this drive, i attempted the more indepth scans, but didn’t see usable file structure come out of it either.  I installed ubuntu and tried mounting drive that way, and also ran straight into a brick wall (mounting was successful, but drive was showing up unpartitioned).  Just as i was about to give up and go find another 3TB drive that i could cannabilize and swap out the drives, i came across my savior…    RAISE DATA RECOVERY FOR EXT2/3/4.  It is very similar to other readers, but had absolutely no issue recognizing drive.  $80 to purchase license for unlimited data recovery.  If you are in this situation, don’t waste time with any other utility or overpriced data recovery service, just download this and give it a try.  Freeware allows to test recovery of small files for free. 

1 Like