My Book Live 3TB disappointment

Well, I thought when i buy a WD product it will work as expected…

Just plugged my 30Min old My Book Live 3TB into my router and tried to make a tm backup under osx lion but it didn´t work. Drive was recognised but no write permission… ( CND IM IN or something crappy…)

flashed the latest firmware and after the regular reboot the same story…

after trying to configure something (which didn´t work) tryed to reset…

since then no possibility to acces the UI anymore… the drive is still in the network availabe but

tried under windoz… no success

tried another comp… no success

direct connection to pc… the same

solution… back into ze box and went to buy a synology diskstation…

I´m very dissapionted about the bad reliability of WD NAS. I´m not going to buy a WD NAS again…

did you by any chance make sure to see if you had the latest firmware update?  because you’ll need it to access Lion.


yes, it was the 2.10.09 FW version to which i upgraded. 

Please excuse my first angry post but I didn´t expect such difficulties with the drive… :frowning:

I think about leaving OSX Lion and switch back to Snow Leopard.


does WD use the latest netatalk / AFP version (payed licence) in the latest firmware?