My Book Live 2TB no longer working with PS3

My My Book Live no longer works with my PS3. The PS3 recognises that the My Book Live is on the network, as it appears as a media server under Music/Video etc, but when I go to select it to browse public folders, the PS3 displays “There are no titles”.

I have attempted to contact WD about this but they have decided not to respond to my raised ticket. The firmware of the NAS is “MyBookLive 02.43.03-022 : Core F/W” and I’m sick of this not working properly. I would really appreciate ANY help on this as typically the device is just out of warranty, I have tried a work around I have seen listed where you create another public folder which I called “test” but this did not resolve the issue.

Background info, the unit worked correctly for a year or so, the files on the My Book Live are all PS3 compatable. PS3 is on latest official firmware. Both are connected via Ethernet cable to my BT Router.


Ah, it appears I have rebuilt the database and that seems to have fixed it…only took me 3 days to figure out!