My Book Essentials 2 TB Not Recognized

I have a 2 TB My Book Essential WDBACW0020HBK Drive that I had connected to a Netgear wndr 3700 router via USB and it functions as a NAS.  I came home after a weekend away to find the device powered off (light off).  I powered the unit on and went to my networked media devices where I saw the Readyshare folder but nothing in it.  I figured maybe it was the router.

 So I took the drive and connected it directly to a usb port on my laptop and powered it on, the drive did not show in windows explorer and this was not the first time that I directly connected the device.  I tried a different USB port, tried going to device manager to see if there was an unrecognized device, tried unplugging and plugging the drive’s power.  I then read an article that the USB cable is faulty, so I purchased a new one off of Amazon.  That didn’t work either.

 I was going to grab a USB enclosure and a Sata cable and try to open the My Book to directly connect to my laptop’s sata port.  However, I have read that some of these drives will not allow you to do this because of encryption that require that they be connnected to a USB board.  Is this true and what are my options?  I would really like to get the data off of there. 


Try connecting the drive on the computer and make sure that the power supply is connected to the wall outlet. Once you do that, check on Disk management to see how is the drive showing.

How to access Disk Management in Windows XP, Vista, 7 or 8 to manage hard drives

Also try testing the drive if possible with the DLG Tool.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows