MY Book Essential quit working

My Book Essential quit working.  Last night I accessed it to play a game, and it worked fine.  This morning when I went to play the same game it would not work.  It told me the network connection was not there,  I looked under my computer and the drive does not show up.  I checked my connection wires to see if everything was still plugged in, which it was.  The light is clinking on the front of the drive, but I on’t hear any sounds from it.

Hi, did you tried connecting the My Book power cable directly to the wall? You can also check if the My Book is recognized by DLG so you can run a test. Check the link below for the steps. 

How to test a drive for problems using Data Lifeguard Diagnostics for Windows 

1 Like

Thanks for the help.  I did try plugging it into the wall, and it worked. 

In order to solve the problem in the lojg run I need to find another outlet to plug it in since the one I used to test is not a usable option for the long term.  Does anyone know if they make an adlapter or USB cable for the My Book that is longer than the ones that came with it?

These drives are very sensitive to voltage and it is not recommended to use a USB cable longer than the one supplied. Part of the problem is many PC makers use barely adequet power supplies and the increasing use of USB devices adds to the problem.