My Book Essential 2tb (power cable) won't detect properly

I’m using a windows xp 64 bit. I have a 2tb My Book Essential and my windows can’t seem to detect it properly. Windows does pick it up and sometimes it even tries for the “autoplay”, which is just basically empty, but then it just kind of fades away…it’s as if windows is trying really hard to detect it but doesn’t go all the way. The drive was working fine and then I updated my windows and restarted the system but I accidentaly forgot to disbale the drive. After the reboot the drive isn’t working the way it should. The light is blinking and the sound’s there…but it seems to be stuck at a state where it’s just trying to read the drive. I can see the drive in “Device Manager” both in “Disk Drives” and “WD Drive Management Devices”. I can even see it in “Disk Management” (via administrative tools) and it shows that the drive is healthy but 100% empty, which it shouldn’t because there’s atleast 1.5tb worth of data in it, and most importantly under the “File system” tab/column it’s blank. It should be NTFS. And the drive doesn’t appear in “My Computer”…instead it just keeps freezing “My Computer” when open it. I’ve tried updating the firmware, using two different updaters, and one says that it can’t detect an internet connection and the other says to disconnect all other usb devices. The internet connection is fine, there are no other devices connected and I even tried it by disabling my antivirus, firewall and spyware/malware detector. I’ve two other WWD drives, a 1tb elements (power cable) and a 1tb passport, and both of them are working fine. Also when I restarted my computer, after the wwindows update, I tried connecting both the 2tb and 1tb passport at the same time. It detected the 1tb quickly because it doesn’t really have much data on it and just kept trying to establish a proper connection with the 2tb. I also tried assigning a new letter to the drive thinking that maybe there was a conflict when I tried connecting the drives at the same time but no luck. It just freezes the “Disk Managment” tool.

Should I try to format my drive through “Disk Management” because it’s not showing the file system? Could that be the issue? I have a data recovery tool incase I format the drive.

p.s I followed the links in this article to get the latest firmware.

I tried accessing the drive via “Disk Management”. It wouldn’t…no error no nothing…it just tried accessing the drive and after a while it just stopped. It froze the “Disk Management” for a while but nothing else. So instead I tried accessing my other, internal, drive/partition and it opened the explorer/folder option view and I could see my external drive on the left but it said Local Disk. And when I tried accessing it the explorer just froze up for a while and an error popped up saying that the drive isn’t formatted and if I want windows to format it.

I also tried WD’s DataLifeguard and here are the results
On the quick test
Test Error Code: 06-Quick Test on drive 3 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 3!

As for the quick test it’s under progress and time keeps flactuating between 20-30mins. I’m not positive that the reults would be good.

I can’t seem to upload a screenshot but in the main menu of the software under the physical drive area it shows the drive and under the Smart Status it shows passed. But in the logical drive area it shows the letter assigned to the drive but everything else is blank

Hello M_Hammad, this seems like a data corruption case, you can try using the data recovery program before formatting, but you should also be able to format the My Book and then run it, just remember to not save any new files. Once you format also try running the DLG test.