My Book Essential 2TB going into Stanby


#1

I really hate the idea of my drives going into standby, and it’s really getting annoying and screwing things up. (it actually makes this drive useless)

I just bought this drive today and so far i’ve been trying the whole day to just zero out STANDBY.

It looks impossible, before i go out and spend some money on a new drive and throw this one to the sea, is there anything i could do?

From my experience with the seagte drives, it was pretty easy, both from linux(using sdparm/hdparm) and windows (using their software) but none of the above (from linux especially which sould work) is working!, i also tried to find that option using windows (western digital software) and i came up with nothing.

Now, i know i have another option of opening up the box but this will void warranty, i wonder if anyone from western digital can confirm that it’s not possible to disable the standby feature?

Thanks.


#2

If you’re using a drive that has SmartWare, you can change the sleep mode to never in the drive settings.  If it’s a drive that doesn’t have SmartWare, then, no, you can’t change the standby mode.


#3

Well, it had SmartWare for sure, i removed it, but right before i did, i couldn’t find anything related to Standby.

I will try this today again (perhaps i was too tired yesterday), anyhow, when i remove the Standby with SmartWare, does it mean it writes into the hardware or it’s software related only (if i put the drive in other OS for example)?

Thanks.


#4

Well, it worked.

I went into windows (lucky i still have it because sometimes i must use it for work and also left 500GB of free space for NTFS only) and loaded the SmartWare, went into Settings and set the timer to 0.

To my luck it’s not software based and it actually clears (zero) the STANDBY.

Before:

[root@infin1ty ~]# sdparm -al /dev/sdb
    /dev/sdb: WD My Book 1110 2003
    Direct access device specific parameters: WP=0 DPOFUA=1
Power condition [po] mode page:
  STANDBY_Y 0 [cha: n, def: 0, sav: 0] Standby_y timer enabled
  IDLE_C 0 [cha: n, def: 0, sav: 0] Idle_c timer enabled
  IDLE_B 0 [cha: n, def: 0, sav: 0] Idle_b timer active
  IDLE 0 [cha: n, def: 0, sav: 0] Idle timer enabled
  STANDBY 1 [cha: y, def: 1, sav: 1] Standby timer active
  ICT 0 [cha: n, def: 0, sav: 0] Idle condition timer (100 ms)
  SCT 6000 [cha: y, def:18000, sav:6000] Standby condition timer (100 ms)
SAT ATA Power condition [apo] mode page:
  APMP 0 [cha: n, def: 0, sav: 0] Advanced Power Management (APM) enabled/change
  APM 0 [cha: n, def: 0, sav: 0] Advanced Power Management (APM) value

After:

[root@infin1ty ~]# sdparm -al /dev/sdb
    /dev/sdb: WD My Book 1110 2003
    Direct access device specific parameters: WP=0 DPOFUA=1
Power condition [po] mode page:
  STANDBY_Y 0 [cha: n, def: 0, sav: 0] Standby_y timer enabled
  IDLE_C 0 [cha: n, def: 0, sav: 0] Idle_c timer enabled
  IDLE_B 0 [cha: n, def: 0, sav: 0] Idle_b timer active
  IDLE 0 [cha: n, def: 0, sav: 0] Idle timer enabled
  STANDBY 0 [cha: y, def: 1, sav: 0] Standby timer active
  ICT 0 [cha: n, def: 0, sav: 0] Idle condition timer (100 ms)
  SCT 0 [cha: y, def:18000, sav: 0] Standby condition timer (100 ms)
SAT ATA Power condition [apo] mode page:
  APMP 0 [cha: n, def: 0, sav: 0] Advanced Power Management (APM) enabled/change
  APM 0 [cha: n, def: 0, sav: 0] Advanced Power Management (APM) value

but i still wonder why “sdparm --clear STANDBY --six /dev/sdb” does not work when it should work (work fine with other external drives).


#5

try hdparm -Z /dev/sdb

the -Z turns off the Seagate auto-powersaving mode.

also hdparm -B 254 /dev/sdb will turn off APM on the drive as well.

you may also have to run hdparm -K 1 /dev/sdb    to set drive keep_features_over_reset flag (0/1)