My Book 4 Power Failure - how can I get the data if there's no power?

Please only respond if it’s constructive - not criticism. I’m already kicking myself and don’t need others to make me feel worse. But anyone who might know what to do about this situation, please respond. Have no idea what could have caused the power to stop, how to get it back on, and/or how to remove the data if the drive has no power.

I didn’t spill anything into, next to, or drop the WD MyBook 4 external hard drive.

In fact it was in the process of transferring files when it suddenly disappeared from the HP Envy PC (Windows 8.1) it was attached to. I don’t know if it matters but the PC was updating Windows security software - as well as transferring (backing up) files from the WD MyBook 4 external drive to a Seagate external drive. As soon as I saw the error message about the failed file transfer I checked to find the drive no longer listed on MyComputer. So I unplugged the USB 3.0 cable and plugged it back in to the computer. Everything seemed fine, but then it happened again. However this time when I tried to remove and reattach the USB cable, nothing happened - which was when I noticed that there was no light on the front of the MyBook 4 external drive!

Since then, no power no matter what I’ve tried. Here’s what I’ve already tried:

1.took the WD MyBook 4 AC adapter and plugged it into a Seagate external drive - the Seagate powered up, so it seems that the AC adapter is ok.

  1. tried using the Seagate’s AC adapter (don’t have another WD ext drive) with the WD MyBook 4 drive - still no power

  2. tried changing USB 3.0 cables with one I know works with the Seagate drive - no power to WD MyBook 4 drive

  3. tried plugging WD MyBook 4 into a different laptop - still no power

So now what? Please help. How do I either:

  1. get the WD MyBook 4 to power up; or

  2. get the data off the WD MyBook 4 ext drive if there’s no power?

Is it possible that the WD MyBook 4 external drive has gone into some kind of protective or sleep mode (a software issue) and if so, is there anything I can try to get it to power up?

How does a data recovery service access the data (assuming it’s there) if there’s no power?

Does anyone know how to access the drive to check the power, starting with how to remove it from the case without causing any damage? Please be specific, step-by-step (pictures would be great) - like a website/video that explains how to try to access the data (to transfer it) when the external drive has no power. Thanks for all of your help and suggestions.

I think that either some piece of hardware has stopped working OR some how a piece of software has shut the external drive down

Hi, welcome to the community.

After everything that you have tried, the best recommendation would be to contact a professional Data Recovery company to get the information out of the hard drive. WD has a few that you can look at  here.

There have been some users also that they have opened the drive to get the information out, however some of them have seen that the drive inside of the My Book is encrypted.

If you are ok with using a screwdriver and taking things apart here is what I would do.

It sounds like the mybook internal power supply has failed. It takes voltage from your walwart and coverts it to voltages the harddrive needs.

Take apart the mybook and remove the harddrive. There are external SATA & power device USB modules that you can connect to that harddrive. Then power it up and plug into your laptop. Chances are your laptop will see it as a working external drive.