Must be doing something wrong on my Mac

bought a MyCloud diskless 2 bay enclosure (EX2 Ultra) which I planned to use as a network drive. My plan was to add one drive for Time Machine (I clearly work on a Mac) and the other as a general use/storage drive to be shared across my network computers. This is a home setup, not a business.

I formatted the shared network drive (HFS+) and added data to it before placing it in the bay and I added a second unformatted drive to the other bay. I assumed that I would be asked to format it when I accessed it on the network but I was not asked about formatting.

I think I followed the setup instructions properly and I do see the network device in Finder but when I click on it and try to log in as Guest nothing happens. When I try to log in as a registered user I am told that the connection failed. Clearly I am doing something wrong but I don’t know what it might be so perhaps it might help if I ask some basic questions.

  1. Are drives supposed to be formatted before being inserted into the bay?
  2. Is it OK to use an already formatted drive with data on it?
  3. Is it OK to use one bay for Time Machine and the other as a general use disk? I did not want to set this up as a RAID device.
  4. What might be the reason that I can not gain access as Guest? Or admin? Or any other registered user?

Thanks for any help. I have blue lights for both disks, just in case that is important.

  1. No.
  2. well, it’s OK to use them, but the NAS will reformat them anyway and delete any data already on them
  3. Sure, use JBoD and set up a separate volume on each disk
  4. don’t know what’s going on there. Post some screenshots – that might help…

I spent some time after posting this trying to understand what the problem was. When I use the web setup screen I am unable to create a share because, so I am told, there is no volume for me to create a share on. I also can not format the disk because the format button is disabled.

I formatted both disks in HFS+ since I was going to use them on a Mac and that is what the Mac requires for Time Machine. I wonder if it is the HFS+ format that is causing the problem. Perhaps I need to reformat the disks as exFAT or NTFS or something else so the setup can see and use the disks?

Or, based on your responses, perhaps the problem is that I do not use JBoD. I will try that next. And perhaps I should read the instructions???

I think I have gotten this all worked out now. My main problem seems to have been that I did not understand that even if I did not want to use RAID I had to go into the RAID setup and select how to use the disks. Because I did not do that I could not create any shares and so both disks were inaccessible.

The manual, which I actually tried to follow, really was not much help and I stumbled onto what I believe to be the solution basically by having first tried almost everything else and having nothing left to try but the RAID setup. However once I actually had a share created everything else seemed simple.

Thanks for the help.