Mov-file turns into jpg-file when copying from Mac photos to MyCloud


#1

Hi there,
I have tried to copy some 500 files (mostly .jpg-files but also .mov-files), but have an issue with the movies. They get turned into .jpg-files when I copy them from the Photo-program on my mac and to MyCloud.
Would anyone know how to avoid that?
Best regards,
Anne


#2

How are you copying the files? With Mac Finder? Are you trying to move the entire iPhoto library from the Mac to the My Cloud? Is the Photo program converting the files to a different format when they are being copied?


#3

Thank you Bennor for your quick reply.

I have already moved my library to MyCloud (by the way, the mac keeps forgetting where to find it - and quite often when I indicate the new location, I get the message in Photos that a repair is necessary. It takes a bit of time but always gets the job done, but makes me a bit nervous!).

The files I’m talking about here is being copied to a different folder on MyCloud (so that another person within the household can access them), and I’m just copying in Photos with cmd+C and placing them on MyCloud via finder and cmd+V. It works for the photos, but not for the videos (they are copied but turns into a jpg-file). I now that you say it, I actually don’t know if it is the Photos-program or MyCloud that is the source of the problem …

Do you have any ideas?


#4

I suspect it’s an issue with the Photos program; when you copy with cmd-C, it copies the thumbnail, I suspect, not the underlying video. The Photos browser isn’t showing you that actual file; it’s showing you a thumbnail.

caveat: I don’t use a Mac.

I’d try copying and pasting purely with Finder. This will mean that you’ll have to figure out just where Photos has put your pictures in the Mac’s file system…


#5

If you are within the Photos program try using the Export option rather than the Copy option and see if the problem persists.


#6

Hi and thank you to both of your for your help.

@cpt_paranoia: You are right. Even the photos have only been copied as thumbnails.

@Bennor: I tried again with the export option (had tried it previously with all files at once which didn’t work), and the result is fine for the photos that are now copied as they should be (the entire file, not just the thumbnail). But the videos now turns into m4v-files and if double click to open from MyCloud, I get “are you sure you want to open Spotify?”! I do not seem to have a choice of file type during the export process … Strange.

@cpt_paranoia: I will thus try the solution that you suggested to copy from finder. But I cannot seem to ‘get into’ the photoslibrary already located at MyCloud … I know that I could back when it was located directly on the Mac. Sorry to be such a novice!

And thanks again for your kind help.


#7

Don’t know if it works for the video files but the image files supposedly will be copied unmodified if one selects “Export Unmodified Origional” from the Export menu option. There is more discussion on the export unmodified option at the following link:
http://apple.stackexchange.com/questions/188510/how-to-export-photos-from-the-new-photos-app-in-full-quality

Further at that link one person indicates the following:

As an alternative to the solutions described in the other answers, you may drag-and-drop from Photos to, e.g., the Finder by holding the [alt] key. Doing so will cause the original to be copied instead of the converted version. This works both for photos and videos.

And supposedly (I don’t use Mac’s) per that same link the default location for the Photos is:
~/Pictures/Photos Library.photoslibrary/Masters/


#8

I have a vague recollection that Photos uses some kind of database structure to hold images, rather than simply having pointers to simple files. I could be wrong…

Sometimes the ‘it just works’ approach is ‘just too bloody clever for its own good’.

I don’t trust things that are too clever…


#9

YES, it worked with the ‘export unmodified original’-thing. Thank you. It seems like a very nice forum where I ended up getting help to Apple’s Photos and not MyCloud! Thanks again to both of you :slight_smile:


#10

Avdshare Audio Converter can Convert MP4, AVI, MOV, WMV, MKV, FLV, ASF, WTV, MTS, WEBM, etc to JPG, JPEG, PNG, GIF and any other image format in batch conversion mode.