Mode Not Supported. Resolution Not Supported on TV


I have brand new 46 inches 3D Samsung D6600 led lcd TV. My PS3, Digital Satellite receiver and dvd is working flawless.

While connecting my WD Live Plus (firmware 1.06.16) it says “Mode Not Supported. Resolution Not Supported on TV”.

Things i tried without success

  1. Swapped 4 hdmi cable (2 Sony, 1 Mediabridge + 1 unbranded cables) All these cables work perfectly with PS3 & satellite receiver.

  2. Rollback firmware

  3. Changed power adapter

  4. Forced settings to 720p & Auto + Color Space to RBG Low

NB. The WD is working fine on my Sony CRT TV via AV cable

Please HELP!!!

Thanks in advance

Try manually setting (force) the WD output to 1080i and RGB Low. Try not using Auto framerate.

I tried but did not worked!

BTW it’s working fine via a component cable on 1080i

Is it a handshaking issue with the HDMI?

You didn’t mention whether this is the first HDMI display you’ve ever tried on the WDTV.  If it is, this maybe a long shot but I ran into something like this when I first got my WDTV Live.   The HDMI socket of the WDTV is recessed into the plastic case and I found that it prevented the HDMI cable from seating fully into the receptacle.  It behaved intermittently and sometimes indicated that the display was not supported even though the TV detected that something was plugged in.  I ended up trimming off about 1/8-inch off the plastic that surrounds the metal plug sleeve at the end of the HDMI cable.  Once I did that, the cable seated fully into the socket and I never had the problem since (over 2 years of use now). 

I have tested it before on a 22in lcd monitor and also on a Sony 32in it worked fine.

Anyway I will check the hdmi connectors and test it on the 22in monitor side by side with the 46in Samsung again.


This issue occurs with a number of digital TV’s. Refer to your user manual; if there is a manual HDMI port calibration or handshaking, follow the manual’s guide and manually set up the HDMI port.

OK. Thanks

I will check and revert back.

Checked unfortunately there is NO manual HDMI port settings. I think it’s a problem with Samsung TV