Manual Update 2.01.06 hanging "import files" for hours

I try to click update but it doesn’t work. So I deciced to manual update the firm ware. However, it hanging on “Update firmware import files” for hours now. What should I do? Keep computer open for whole night? Anyone help. Thanks.

a few of us have that problem too, you’ll see in the firmware thread.  One person suggested updating SmartWare first.  I didn’t try that yet.

Finally got mine to work doing the manual import.  Tried all 3 methods multiple times of using the Smartware (Wouldn’t download the update, nothing happened), automatic checking, timed out the last two times I tried with that 4647 kb error.  Finally don’t know what I did different but after a few attempts to import the file manually, it picked it up after a minute and started upgrading.  

Almost had a heart attack from the surprise that it was working.

The problem solved, reboot the MyBook Live will do the trick, it works perfect using just “update” botton. No need manually instead at all. 

1 Like

same here.  1.05.07, couldn’t get any update to work, and couldn’t get MBL to shutdown.  finally pulled the plug after it went to sleep.  gave it a rest, plugged in, and 20 minutes later did the settings/web update and it went just fine.

Same problem when trying to update from 1.05 to the 8/31 release of 2.02.02.    I lost access to the MBL Menu , so I used the manual reset button on the back.   After waiting about 5 minutes on the steady green light,  I tried the manual import again and it started right up.   I still think there is a bug in the MBL when firmware is loaded that causes you to reboot.   It seems like people have alot of trial and error with this device which doesn’t make me too comfortable using it as a storage device.   I may buy an external hard drive to link to the network and then have MBL back it up secondarily and use it for internet sharing. 

Ever since my daughter got a new Macbook and has been unable to use the WD Live NAS as a Time Machine backup I have been trying to update the firmware. I have tried all the things on this page (manual check for update, check autmoatically, download and import the file) and none of them worked. Each time, it just seems to hang or time out… The one thing I have NOT yet tried is unplugging the NAS and plugging it back in.

I will try that when I get home and see what happens.


Nope. Still hangs…