MacBook Pro No Longer Recognizes WD My Passport :(

Unexpectedly, my MBP stopped recognizing my WD My Passport external hard drive.

Mac: Mid 2010 15" MBP

OS: OS X Yosemite (10.10.5) … in the process of downloading and updating to OS El Capitan

Mods: Increased RAM to 8 GB

External Hard Drive: WD My Passport 1 TB


S/N: [Deleted]

As mentioned earlier, my MBP stopped recognizing my WD My Passport external hard drive last night. Leading up to this, it sat for about 5 or 6 days while I was away exploring Yosemite National Park. When I got home, I transferred over 20 GB of photos my hard drive which was estimated to take 5 hours. I let it up transfer while I slept. In the AM, I unmounted the hard drive and let it go while I was at work. When I returned home I moved photos in the Lightroom and did a few edits before calling it a night.

Yesterday, after connecting my external hard drive it was not recognized. However, when connected it lights up and I can hear the HD spinning when I place my ear to it like it normally does. Disk Utility does not recognize the HD, but WD Drive Utilities (installed after HD stopped being recognized) does recognize the HD when its attached.

I purchased a powered USB hub today in case power was an issue, tried 3 different USB wires, attached it to a Windows PC and none of these resolved the situation. I will be connecting it to another MBP later this evening to see if that produces any results. Also, since it is a WD HD, I do not think I can open the case and transfer the bar HD to another case.

Before I pay a professional for data recovery, is there anything else I can do? What ***** is I’m in the process of buying a new external hard drive set to have duplicate copies of my files (particularly photos and video). I know I should have had dual backups but live and learn. Any suggestions will greatly be appreciated!

1 Like

I wish I had a resolution for you, but I’m actually planning on posting about the same problem. I noticed no one has replied to your post, but I figured I would at least see if you were able to resolve your problem yourself and share what you learned with me. - You also seem to be more technically savvy than I am, so if you couldn’t figure it out, I probably won’t be able to either.

Several considerations on my situation:
• I’ve had mine about 5 years and it’s always acted strange at times
• Since getting a new cable 3 months ago, I haven’t had any problems using mine
• A few days ago, I transferred some data, once it was done, I hit the eject icon in ‘finder’ and then I got a message about disconnecting at the wrong time, would think that would corrupt data maybe, but not make it not available.
• Plugged it in today, and it only recognizes the drive utilities as well.
• Looking to see if there are drivers to install, but I don’t even know where to start.

I’m having the same issue. Restarted my mac and the drive won’t show up on the desktop AT ALL. Tried different USB cords, tried the other ports on the laptop, NOTHING is working. Anyone have solutions???

I have exactly same Issue two days ago with “My book for mac 3TB” October 2014. I was using photoshop and I had to restart and that is all, External HDD is gone forever.
I tried to use WD drive utilities and I upgraded Firmware. I have also ran other recover sw utilities and nothing is working.
I am going to start the RMA process.
Sorry I have not solution it seems hardware problem or… maybe virus?

Same exact issue here, just got a my passport for mac 2tb a week ago and worked fine for about 4 or 5 days. I was downloading some extra content for mainstage and my mb pro stopped working, made a reboot and Puff, the hard drive is gone and can’t find it anywere except in system info under usb devices but that’s it. Why WD doesn’t give a solution for this?