Mac - Able to map and see folders on MyCloud but not able to see files

I have been using MyCloud with little to no problems for quite some time with my PC. I recently bought a MBP running Sierra 10.12.2 and setting it up now. I was able to set up a share to the MyCloud and I am able to see all of folders, but it will never display any files inside any of them. I am able to view the files on the MyCloud, on my pc laptop no problem.

I also have a My BookLive attached to the same network which I was able to map and the files on that device show up just fine so its not a slow network problem. I tried copying a small file to one of the folders, and it just sits there and spins.

I also hooked up a WD 2TB Passport drive to the usb on the MyCloud. I can access it as well and see the folders on it, but still no files are visible.

The WDMyCloud has updated firmware as of today on it(v04.04.05-101). I have reset it, logged in as admin with all rights. Have spent most of the day looking online to find a solution with no luck. I’m trying to use it to move data from my PC to the the new Mac.

Any help would be appreciated.

Jeff

Hi,

I suggest you contact WD Support about this.

Thanks Feragui, I did that already. Still waiting on a response from them.

Last night I decided to try a work around. I had installed Parallels with Windows 10 on it so I can run a program I use at work that only runs on Windows. Through that I am able to see the shares and see those files on that share.

So the folders and files are visible if I’m viewing through Windows 10 through Parallels. I can only see the folders only if viewing through finder.

Odd but it seems to work for now. I might move all the files off to an extra backup drive, do a full reset on the MyCloud and try again.