Looking for the old Discovery Tool

#1

I have a Gen 3 WD TV Live box which must have come with a software disc but it is lost. I found, downloaded and installed the new Discovery tool but it does not do what I want. The old program used to find and mount my USB drive that is plugged into the WD TV box when Win 7 failed to do so probably due to configuration issues.

This software tool had a black banner along the top with some simple tools. The new blue shade one sits on the side of my screen and does not have any of that functionality but seems to be about cloud management.

Is the original CD or .iso image of the CD that would have come with the WD TV live available anywhere? I have searched here with no luck.
Thanks in advance for any help here.

#2

Do a google search for WD_Discovery_v1.80.zip . You will finde what you need to download.

#3

The Old Software (i remember using it for my WDTV Live Hub) was originally called “WD Link” and it looked like this …

i downloaded and installed it (to take the screenshot) from below

#4

WD Link must be really old. When I got my first WDTV Live Plus in 2010 the tool was called WD Discovery which i had to download and install. Within a month there was a new (and final version, v.1.80 posted). I downloaded it and installed it and it is still on PC today and I still have the original zip file stored in a backup area of the HD.

1 Like
#5

Impossible, you’ve got your years mixed up … the 1st Version of WD Discovery came out in 2016

Releases Notes and Dates prove it : https://support.wdc.com/download/notes/Discovery_3.2.256_Release_Notes.html?v=782

Note: there is No such as version as “1.80” for either WD Discovery or WD Link … so, i dunno where you got that version revision from, but if it did have a limited release it would have been around 2017 before Ver 2.X.XXX release.

I found the WD Official Download page for WD Link … which version 1.00.03 came out in 2011

#6

Ok I discovered I have the first release of WD Link installer you mention (my file is dated Jan 2012.) As I recall, it replaced WD Discovery, but I never installed it since all was working for me. It was for newer models than mine.

Yes; there really is a v1.80 and it can be downloaded from sites. I did get my Discovery v1.80 directly from WD downloads in 10/2010, but it was replaced by the WD Link for the 2012 WDTV models.

#7

So, you are saying WD released WD Discovery and then changed it to WD Link and then back to WD Discovery ?

And the version of WD Link you have is from 2012 when the last version was released in 2011 ?

And when there were no WDTV Models released in 2012 ? (Hub was 2010, Gen 3 was 2011, Gen 4 was 2014)

#8

Joey
You misread my comment. Again, this is the chronology:

I got my first WDTV in fall of 2910 and installed the current version of WD Discovery (v.???) and shortly afterward WD released an updated version, v.1.80. The date on my zip file is the date I downloaded it (10/29/2010). It appears it was created in Aug/2010.

A couple of years later i looked at WD site for a new version and found it was released as ,WD Link in fall of 2011, and I downloaded WD Link in Jan 2012. Got it now?

1 Like
#9

Thanks for the help. I downloaded the Discovery tool V1.8 and ran it. ALthough the screen is different to what I had which had a split screen with the left side having a white background where the info would appear this one seems to do the same thing; search for and mount network drives. Have not tried the WD Link tool yet.

For some reason my original install and setup never worked properly when I turned it on. I had to run Discovery and then I would get access to the drive over my home network. We got a new PVR and optical modem from Telus and all that stopped working. Yesterday I used the safe wireless connect button on the new modem, ran auto find on the WD box and it now seems to be working correctly.

Getting these media players to work properly on Windows networking software is chancy at best.

#10

Glad it is working with WD Discovery. I presume WD Link is same sort of program, so try it, too.

#11

Joey,

There is another WD Discovery program for users of My Cloud Home, I believe, so 2016 date sounds about right for its release date.

#12

i was talking about official release dates, not when you got around to downloading it.

yes, i understand your semantics now.

#13

i am glad it is all clear, and I did not imply that WD Link was renamed Discovery. I suggested WD reused the Discovery name on a similar program for the Home devices.
Movin’ on from here.

#14

Well I downloaded and installed the older version of WD Discovery V1.8 but it fails to find anything on the network at all. Also, this is not the one I used to have. The screen layout is different although in the same colours.

I downloaded WDLink and it finds the WD device and the drive connected to it. Thanks Joey Smith for posting that. Not what I had but it works!

#15

As I supposed, WD Link was for 2012 and beyond WDTVs and likely not for earlier models. Nice to know Link worked for you.

#16

I appreciate the help I got here. New to this forum as I really had no issues using my WDTV box for the most part. Still happy with it although in the early goings before some updates it was so slow to boot up I kept thinking there must be something wrong. Seems much quicker nowadays but as an obsolete product one has to manage expectations! Nice to have a support community. By the way, if that is your name and BD you and I share two things in common Mike!

#17

Cool, so we share same name and b-day. Nice.

BTW, I never turn off my WDTV so it is always ready and saves on wear and tear. Been doing this for 10 years.