Local Network Connection issue using Windows 10

Have a WDMycloud device. I can connect locally (ethernet) to the Dashboard ok . But can not map the drive locally to our Windows 10 PC. Can map it ok to the MAC devices.

Have turned on the SMB 1.0/CIFS File Sharing Support ON, in the Windows Features.

WD Firmware = 5.14.105

Log files show
Log = CIFS: Authentication for user [GUEST] has FAILED.

A lot of people have had similar problems with Windows 10. The solution below worked for me (ticking 2 of the 3 SMB settings, not just 1), however there are several other possible solutions throughout the thread if that one doesn’t work for you:

Yeah thanks, been through all sorts now trying to get this sorted, without success - or any meaningful help from WD Support. I guess I should have started the thread with, upgraded from OS3 to OS5. Still works with MAC ok, but does not work with Windows 10 Pro (it worked intermittently with OS3 - before upgrade.)
Thought this thread would be handy…

The above thread looked to be helpful. But other than spending a lot of time it did not produce a useful outcome.