Local access - files and folders not visible

I activated the local access and copied some folders and files in preparation of discontinued support - test. Those are not visible via the web and not visible via Android app. They are only visible trough local access. In addition there are files that I uploaded using WD Discovery integration to Windows Explorer when I was on an other local network connected via internet to the home network. They are there but I cannot see them at all.

Operating system Win 11, 2 drives 9.04.0-191 firmware

I assume these are user access issues. I have not yet tried the free program if that works.

Has anybody been able to solve the access issues? I have to be able to see all of the files where ever I am.

Perhaps read the alternatives that others have proposed, some working right now, this one for example:

Notice below, this Win10 laptop client is on via a Wifi hotspot but is able to use Win File Manager to access remote routing from the My Cloud Home which is on 192.168.1.xx on a different subnet and ISP, copying >100 files in a folder from the MCH. This is made possible by advertising a Tailscale Subnet Router in software from the 192.168.1.xx subnet. Instruction setup in Post 12 below.

I have the exact same problem. I activated local access, as WD sync is not working anymore.

Files created in the cloud/browser do appear on file explorer.

However files uploaded, moved, deleted from the file explorer, are not visible (synced) on the web version.

Did you manage to make it work?

The original poster has not reported back, however this is the expected behavior when the following has occurred:

  • A sufficiently large number of file/folders have been copied to the MCH
  • or A Clear device settings has occurred.

What is happening is that indexing the MCH is a slow process and changing file permission on a lot of files and folder is also a slow process. The files can be updated nearly in real time in the SMB and the Debian files system on the MCH, but updating that information to the webapp will take some time.

reset local permission
no loss of folders, but changing permission can take tens of minutes where the folders don’t show up in the webapp.

folders begin to reappear after new credential is set via ‘enable local access’.

HELP!!! Yesterday I was able to see my files on My Cloud Home on my local drive of my Mac. As of last night I don’t know what happened but now I cannot see them at all!!! I can see them when I login on the web app but not on my local access. It says I’m connected and I can see Public and TimeMachineBackup but not my MicheleMyCloud files and folders!!! I have tried for the last hour to connect, reconnect and rebooted my device. I am so FRUSTRATED as I am not really that literate with behind the scenes computer stuff!!!

Your problem may have nothing to do this thread.

Most Apple users would try to read the Apple community forum and read about the SMB access hack that they have to run in order to work with some versions of macOS.

User level: Level 1
50 points
Nov 9, 2022 6:02 PM in response to edwin jo This seems to be the best solution. Many thanks to all who participated.
PS - I just updated to Ventura 13.0.1 which does not fix the problem, but the turn off file sharing → reboot → turn file sharing back on still works.

Like I had mentioned, I am not well versed w/ what issues are the cloud or my Mac. Thanks for the info.