FIles with new Local Access can't be read

So as said if i use the windows explorer with the new local access on update 8.12, i can’t access some of my files. It says i have no permission to read them

Any solution for this?

On web and wd discovery they are fine

2 Likes

Same issue here. Since enabling local access I can access some folders but am denied access to others. This is a joke. WD is not fit for purpose. Wish I’d never bought into this

1 Like

Seeing that so many users are experiencing the same issue (inability to access My Cloud Home files with local network access on), I’ve decided to wait for the next firmware release or better setup instructions.

Mate do a backup with wd discovery or download them via web app (must be a zip file) and then copy back them, if they don’t ask anything you will regain permissions

Yeah, that’s all very well for the files that are on the User drive but I am denied access to the files in the Public folder which contains my music library and have no other way of being able to access them. WD Discovery cant connect to the drive so I can’t back up

I have access to the public folder

Maybe try to disable access to your user drive and try again to connect like in old times

One does not need WD Discovery to access the Pubic folder. Try using any Linux variant Ubuntu or Debian on the same local LAN and one should be able to read write and delete files in the Public folder. It would be useful for others to know what OS is being used and what SMB version is being supported in that OS.

Using MacOS 13.0.1. I agree that one should be able to access the Public folder to read, write and delete files after enabling local access. However in my case I can’t. I have one folder in Public and it has a no entry :no_entry: icon on it.
This whole access situation is ridiculous. It’s like having keys to my own house but having to get permission from someone else to use them. The WD drive is mine not WD’s or anyone else’s. I never had a problem with accessing files until they started messing about and introducing 2FA and since then its been a complete shambles. Never buying WD products again

Nobody can keep up with what Apple is doing with their SMB updates. Try not to update to the latest and greatest macOS if one values compatibility with third party hardware. There is a good reason Apple doesn’t sell a NAS because it is likely they couldn’t keep up supporting it and they won’t make very much from its revenue.

[Issue]

macOS 13 Ventura has changed the query structure in Finder search which caused a compatibility issue with SMB and AFP protocols.

You may encounter :

  1. No search result by using SMB protocol
  2. Finder hangs by using AFP protocol

Judging by the number of other posts and topics reporting the same issue, I’m not sure this is an Apple problem more than a WD one. If developers claim to be at the forefront they need to be able to back up that claim

Any reasonable user would have just returned it and got a refund. WD MCH is the cheapest cloud hardware in the world that works (some US consumers got it for < $100 for 4TB). If you can find one cheaper and better, please name it.

Please go research all available NAS type device commercially available in similar price range and try to name one that works properly with macOS 13 Ventura. If Synology can’t come up with a fix, it is likely no one has done it yet. Think about it, Apple wants users to use iCloud, what possible incentive does Apple have in supporting third party NAS?

That’s just a defeatist attitude. Just because “Company A” doesn’t produce one doesn’t mean the rest of the world has to sit back an say “we can’t produce anything better” - that’s the whole point of R&D. WD have been a market leader for years and have produced good products, but they have fallen short with the software in MCH products. It’s almost like they’ve thrown the MCH into the market and taken the attitude of “just get on with it”. Yes, I picked mine up for under £100 but that was because it was what I coud afford at the time. I work from home and cannot afford £2.5k on a Synology NAS.
The MCH worked fine to start with – I could access it through WD Discovery and the Finder on both Mac and Windows systems but since they introduced the 2FA and new firmware I have had nothing but problems accessing it.
It’s not rocket science!

Wow! Conspiracy theory with a PowerPoint slide! I think that’s a whole different forum!

C&P from a different thread.

I’ve just managed to change the permissions by cutting a folder from the MCH using WD Discovery and then browsing with the desktop app and then pasting across the network to my windows 11 laptop. Then I cut and paste it back using my mapped local drive link. It works for me.

Bit more detail. I opened file explorer using the MCH desktop app icon which opens to Y: and then I opened a new explorer tab which is a folder on my windows 11 laptop. Finally I opened a third tab for Z: which is my local mapped drive. I cut from the Y: tab and paste into the Windows laptop folder. Then cut from the laptop folder, you may need to deselect the file/folder, and paste into the Z: tab. I refreshed the Z: tab before pasting.

It looks like they changed something in the on-disk representation of your data with version 8.10.0.
The files created with previous versions are not accessible via SMB local access once you enable it.

You can download and reupload the files as a workaround using the MCH desktop app; after that, your file will be readable through the SMB protocol.

1 Like

This solutions worked like a charm.Thanks!

This is indeed correct as several users have pointed out. However, the use of a USB drive, more specifically a USB 3 SSD that can read write >500 to 900 MBps can be a much faster alternative than SMB (~100 MBps). The following is a MCH type device connected to a USB3 SSD, controlled by the WD MCH web browser app.

For those who are wondering if it is possible to just change the remote read attribute of files on the MCH from the client OS (Win or mac), the answer is no, not until WD MCH team provides such a tool.

1 Like

You are right. Using a local USB3 drive will be more efficient, especially if you have a lot of files.