Latest Recovery ISO not working

Hey guys,

I just downloaded the latest Recovery ISO for our DX4000 from WDC and tried to run the setup program from it to create the bootable flash drive, the instructions say it has to be at least 11GB big, well, I put a 16GB on my computer and it doesn’t recognize it, then I tried a 32GB, this one it does recognize it, but all it does is format it, nothing is done to it.

I’m trying this because for some reason after updating the software on it, the Info icon shows that fan is not sppining (o RPM) and the CPU has a temperature of -1, so I was wondering if doing a full recovery will fix that.

Any ideas?


Check the md5 hash of the download to be sure it is good.

As well look over this threadand check if you have any similarity’s.

Finally dbl check that the date on the server is correct

I will try that first thing next year, if it works, you’ll get the kudos.

It does look similar, but I tried what it’s said in it and nothing changed, any other ideas?


not really.  your date is correct?

Yes it is, I just opened a support request to see if technicians from WDC can help me better.

Thanks though.

If you can let us know the outcome in case anyone else has this issue.



I will.

It might be very similar to the one you sent me before, only in my case, my box did have the correct Product Number in the registry.