Lag / Slow video and file playback Wd my Cloud Ex2 ultra

Hello everyone,

For a week now, after updating the cloud to 5.23.114, the playback of videos via Sony Bravia TV (with twonky server) or VLC by iPhone or iPad is jerky. The videos load but they crash after a random time on the TV and lag heavily on VLC.

I also notice that overall wd cloud is slower, whether to access the admin interface or browse files (even copying some folders/files crashes).

I tried to switch back to the old firmware version (5.22.113) but without better results. So I deduce that it is not the last update that causes the problem.

I’ve never had any network issues before (and by the way I don’t think it’s from the network) and the cloud (even remotely via the app) has always worked fine.

Do you have similar problems and other solutions (a particular configuration)?

Thanking you in advance for your help.

Hi @mcollette,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

The system is not doing an indexing task, is it?

Hi everyone,

Thanks for your reply.

I have not yet opened a support case. I will do it asap.

I don’t think that the system is performing an indexing task. How can I check this?

I noticed that it also depends on the movie. Maybe there is a specific codec or media (mkv for example) that works better.

Best regard!

How are you playing the movie?

If it is through plex; you need to stream at native resolution. The EX2 ultra simply does not have the “horsepower” to transcode video on the fly.

PS: Please report back if the “support case” actually provides meaningful support. :wink:


I use Twonky server to play my videos on TV but I don’t think that it’s a resolution issue because I had no problem before the firmware update.

However, I have some good news because the system seems to be working properly again.

I downgraded the system to the old firmware version (5.22.113). I performed a reset of the system. I configured the NAS again. A this point, the cloud still had some lags. I connected the NAS to the WD cloud via my identity. The indexation was done (around 6 hours) and since then I have not had any problems.

But I still don’t understand what happened. And I don’t feel like updating the firmware to its next version at the moment.

Thanks for your help!

Same fail here, last 3-4 days is lagging like ■■■■ on my Sone Bravia TV, Tryed install dif plex server, nothing help. Lags start after 20-25 min playing… Direct Stream , no transcode.
I have test the Plex Server from PC, same movie no lags. Its the ■■■■ WD My Cloud EX2 ULTRA, really sad


I was able to solve the problem by completely resetting the system to the latest version, setting the time zone to Dublin, Edinburgh, Lisbon and London and disabling the shutdown calendar. If any of these options are changed, the system crashes again. So far, I have not had any more cases of slowdown.

Best regards,