Just 'black' when trying to view a picture

#1

I have a MyCloud, with firmware v04.05.00-334.
Recently, trying to view pictures that I uploaded to it, I get just a black screen. It shows the info at the bottom, and the X to close (just like when displaying a picture that works) – but no picture. About half the time it’ll show a ‘broken picture’ icon.

Yes, it’ll display some pictures fine; it seems like ones that were uploaded months ago are OK. It’s just the ones that I’ve uploaded in the last month (or 3?) refuse to show. And, the ones that don’t show also don’t have a thumbnail (just the generic icon). I can download it, and the computer will display it.

This is for pictures that I upload from my computer (using the web interface) and from the Android app.

Was there a firmware update that broke this?

Can I fix it?

#2

Forgot about 1 detail –
It’s just the computer (Firefox) that doesn’t display the new pictures.
Using the Android app, I can view them – but still get a generic thumbnail for the ‘broken’ pictures.

#3

@Michael-K I just tried this on my desktop computer using Firefox and have the same problem with the last two pictures that I took.

Have you tried a different browser? I am about to try Chrome.

Just tried Chrome and none of my photos will show, gives me a server error and says to contact WD. I am going to reboot my My Cloud and try again.

I did the reboot and finally was able to view those two photos, however, it didn’t last long as it started acting up again. If it’s a problem on WD’s end hopefully they will get it corrected.

#4

No, I didn’t try any other browser. I use only Firefox.

Update
I rebooted the MyCloud, and things work properly now.
I wonder how long it’ll last.