Jpg image transfer is s-l-o-w


I searched through the other forum posts, and could not find anyone with my situation, so forgive me if this has been asked before.

I have a large collection of jpgs that I want to access from various computers and tablets. The images are stored on an external hard drive connected to a windows-7 pc, and I am trying to copy them to my new 4tb mycloud. The problem is that the transfer speed is rediculusly slow, (usually around 1mg/sec), and heaven forbid if I try and do two things at once with the mycloud, it boggs down to as low at 50kb/sec. I have spoken ot wd tech support numerous times, with no solution, but I do know that my lan write speed is at least 100mg/sec to the mycloud, so I don’t think it has anything to do with the computer, or the network. The external hard drive can transfer jpgs to my “c” drive at around 20mgs/sec, incidentally,so I don’t think that is the bottlneck.

I have tried to compress the files, transfer them to the mycloud-which is way faster, but then uncompressing them is even slower than copying them to begin with.

Does anyone know of a way to optimize the mycloud to handle jpg images, or maybe converting the jpgs to another format that the mycloud can handle better? I am to the point where I am thinking of returning the mycloud to get my money back, if this is how slow it’s going to be.

Thanks for any help.

You found the answer to your question. Which is, transferring one chunk is always faster than many pieces.

But when you tried to unzip, the zip file is being transferred back to your pc as one piece then transferred back to the nas as several pieces. This round robin effect also happens when you’re transferring from one share to another though they are on the same nas. It’s just how samba share works. 

What you could do is;

  1. Zip the jpgs into one file then transfer to the nas. Take note of the location.

  2. Enable ssh in the WD dashboard webgui. Ssh into the nas using putty.

  3. Change to the path where you uploaded the zip file then unzip.

    cd /shares/my-user-name/my-photos/


1 Like

Are you using windows explorer with a mapped drive ?

I find large file transfers are a lot quicker using FTP and a client like Filezilla.

You can enable FTP in the Dashboard and the Filezilla client is shareware.

You can also set it to ignore files that already exist.

Hope that helps

thank you for your responce, I haven’t tried your soulution yet, still trying to decode it all, I should have mentioned, that I am just an end user, with little computer knowlege.

Anyhow, your answer only leaves me with more questions, I wonder it you would be willing to explain to me:

If the “round robin” effect is what’s slowing me down when I unzip my files,-which I’m sure it is, why is this action so much faster using my old external drive connected through USB 2 than to the mycloud which is connected via ethernet wire? I mean if USB is so much faster, then why don’t we use that cable to connect to the internet, instead of cat-6?

And, why is it so much faster to download a high resolution image stored on a server halfway around the world, than to move the same image halfway across my house?

Thanks again!

Thanks Gibbylinks for your answer.

I believe i am using a mapped drive, that is one of the things that the WD tech had me do one of the times that I called them. I’m not sure what a “client” is, and haven’t tried Filezilla yet, but it sounds simallar to Teracopy, which I am using, and does seem to be a tiny bit faster than moving the files with explorer. I can also set Teracopy to ignore files that already exist.


It’s just a different protocol. Not just wdmycloud, the round robin effect exists for all nas with samba shares. You can argue to use usb cable is faster but usb doesn’t support networking. Then again you should have done some research on what you need as a storage, nas or usb.

For your second question, have you tried unzipping or moving files across the world with samba/cif shares? It’s impossible without vpn protocol. You would have to choose a different protocol ie s/ftp or http to achieve that speed you mentioned but much faster done across your house than across the world.

what firmware version are you on?

the thumbnail / indexing process on 4.00.00-0607 really killed the performance, the newer version handle it much better

thanks for responding larryg0

wd tech support had me update to the latest version of the firmware, which made absolutely no difference.

I just finished trying to transfer some files from my c drive to the cloud, and it clocked in at an astounding 15kbs. the cloud is JUNK.

Thanks for the information Nazar78, but it really does not help to tell me that I should have done research before I bought the cloud. Like most cloud users, I am not a computer geek living in my parents basement, with all the time in the world to read about tech all day.  I have a requirement for storage, I looked at the puported specs of the my cloud, which seemed to fit my requirements, so I bought the stupid thing. Please do not reply if all you have to offer is snarky, superior minded responces. thanks.

Like many other cloud users I’m no computer geek but I have the interest and make effort to research about the house, car and stuffs that I bought.

The problem is with your setups not the stupid thing. Next time if you don’t like to research just only use the search functions and do not post for help at all if you still have this kind of ignorant but arrogant attitude.

I had offered personal help previously by remoting to other user’s cloud, they are now happy users and you might be next in the list. But then again, dream on that even WD’s tech could solve your issue with your improper setups (transferring USB to PC at 20MB/s and expects USB to cloud at 100MB/s?). Need not reply I’m out of this thread. Duh~

Can go through the following steps to provide some more information about your system and network environment that may be useful for folks troubleshooting your issue:

  1. Please identify you basic network configuration  (i.e what sits between your PC and you WD MyCloud)

    e.g. PC : Router : MyCloud or 

            PC : Router : Switch : MyCloud

  1. do you have any other wired devices connected to your network?  (If so you can try disconnecting them so see if it makes a difference – unlikely – but worth a try)

  2. iwhat are the nominal network speeds supported by each device in the mix  (e.g. MyCloud is gigabit (1000), if you have a newer router it is likely gigabit, where as PC older than a few years may have a 100 Mbps card)

  3. try downloading a network speed test program (I’ve used LAN Speed Test Lite  – available here: – it’s simple and free – you can use another program if you prefer) – Run the file transfer on a mix of file sizes –  persoanlly – just used 20MB and 5MB file sizes, but you can experiement try something in the range of your typical file size – you should get a generally consistent feel for transfer speeds)

  • Speeds are reported in megabits per second (Mbps) : (not to be confused w/  megabytes)

  – if you have a 100 megabit lan card on your PC you should see transfer rates in 60 - 70+ Mbps range – note the read should be a little faster than the write)

  – gigabit multiply by 10 (600 -700) and 10 Mbps(divide by 10) – 6-7+

  – if your transfer rates are not in those ranges there is likely an issue somewhere w/ speed negotiation (I just went through this type of issue myself)

  – the test files uses a non media test file – so if there is an issue specifically related to media files (JPGs, the above speed test should go well and everyting come up normal)

  1. If above produces no useful leads take a look at the reply to  My Cloud now super slow after firmware update by Bob59 on 07-21-2014 @ 11:01 AM – he offers suggestions for temporarily disabling the TWONKEY media server auto indexing, and initiating a manual index rebuild  – worth a try…  TWOKNEY is accessed on port 9000)  – e.g.  (the IP address for your MyCloud device will vary)

Hope this helps…