My Cloud now super slow after firmware update

Transfers drop out, transfers that used to take 1 minute now taking 10 minutes or longer. Absolute disaster. I haven’t done anything except allow My Cloud to auto update the firmware to v04.00.00-607. 

Any help? OR do I sit and wait for a fix? I appreciate any assistance. Thanks.

paulfe wrote:

Transfers drop out, transfers that used to take 1 minute now taking 10 minutes or longer. Absolute disaster. I haven’t done anything except allow My Cloud to auto update the firmware to v04.00.00-607. 


Any help? OR do I sit and wait for a fix? I appreciate any assistance. Thanks.

Hi paulfe, this issue is currently under investigation. 

1 Like

Thanks for letting me know. I will wait patiently and hope!

I’m worried I could be waiting for weeks. Not sure why they just don’t post a download to roll back to previous version of firmware. That might help everyone in the interim why they address the bigger issue. MY Cloud is effectively a nice storage device at the moment. I can’t transfer anything to it without it taking hours and hours. Frustrating!!

P.S. Managed to turn off auto-update. Will never make that mistake again.

I am waiting too. Please offer the previus Version for having quick work around.

Isn’t it about time that WD responded to this?

I now have a WD drive which is just about useless because it is so slow! Some files won’t open from the drive and I cannot transfer them because the transfer times out :frowning:

I read the reviews before I bought it and all seemed OK, WD have issued a firmware update which has caused numerous issues and days later they have still to respond! I have emailed support and raised the fault on their system, still no response…

Not very good customer service, makes me wonder I bought the rubbish in the first place. Two years support was the promise,  have only had the drive 5 weeks and they aren’t giving support… complete waste of time and money. I have spent four days trying to get files OFF the drive, but it is taking so long it’s annoying!!!

Does anyone from WD care to comment?

Same problem, accessing files is painfully slow.

Same problem here. Very slow transfers, dropping out, stopping outright. Can we have an easy way to downgrade firmware to the previous one while we await a solution? Thanks

I had the same problem; at first the best i could get was about 240k/s transfer speed when it did not drop out. Please also note that I am connected to a wired network, running WDMyCloud s/w from a win7pc which is also running Plex. The MyCloud drive also has a WDMyBook attached on USB and both drives had to be rebooted after the firmware update. It took a good hour before the drive finally initialized enough to even attempt file transfers again. Speed now seems better up to 2mb/s approximately but the USB drive is presently disconnected…

Thanks for looking into this.

I sped things up by doing the following:

Disabled Media Sharing, Itunes Server,  Cloud Access, and Time Capsule.

I also deleted quickview from my desktop.  The Media sharing seemed to speed the UI up the fastest.  

I use XBMC on a FIre TV.  Time will tell if this works.

Granted, I basically deleted half of the devices functonality.  I did not need it.  Others may.

Hello from germany,

the same problem with my system!

@WD: the cloud is useless in this speed! Pls sent update soon, else we have to sent back for use another system!

Thank you

For the germans:

Seit dem Firmwareupdate extrem langsam! Abspeichern einer kleinen Worddatei fast eine Minute.

Neustart, Routerreset etc etc bringt gar nichts. Fehler tritt sofort nach dem Firmwareupdate auf 4… auf.

Bitte liebe Spezialisten von WD: Bringt schnell ein Update oder setzt vorübergehen auf Version 3… zurück.

Das Gerät ist in diesem Zustand vollkommen nutzlos!

Hello from Houston, TX.  Owner of a 3.0TB MyCloud

First post, and it is a bummer that it’s about the horrible speeds after the FW update to 4.0.

Typical speeds after the FW update:

Copying/Pasting from SSD to MyCloud - avg 2.5mb/s.

Cutting/Pasting from SSD to MyCloud - avg 2.0mb/s.

Internet Speeds - 120MB down, 12MB up.

Pretty sure these speeds should be somewhere in the 50 mb/s range?  

I’m glad I’m not the only one experiencing these issues.  Obviously something within the 4.0 update has severely screwed up some of the technical details.  Hopefully this doesn’t lose WD too much business but it looks like they’ve pissed off a lot of folks.

Further to another post I placed yesterday, things seem to be much better now - 24 hours later. I think the problem is that we users jump right in to copying files etc to see the “improvements” but the reality is that the device seems to be quite slow to initialize and rescan all our files after a reboot. 

The dashboard (for example) took at least 10 minutes to show the basic data and another hour to finish scanning all my files (nearly half of my 3TB drive). This process is slow and also hampers any other communications to the drive (like a virus checker running at 80% of CPU capacity), so trying to communicate with the device during this period simply makes things worse.

Therefore I have 2 recommendations:

  1. After you update your firmware, leave the drive alone for a few hours, then check your dashboard to see that the Scanning Drive has completed.

  2. For WD: A note should be added to explain this (if this is actually the problem) situation so that we, the users, understand what will happen when we update the firmware or simply reboot the device. This would greatly enhance the perceived reality of the service you are providing.

Overall I am quite pleased with the quality of the product and really enjoy my NAS 3TB WDMyCloud and is daily use it works great (as long as it’s not scanning my data while I’m copying to it at the same time).


I was able to screen-cap one of the transfers.  I went with a small batch of files, 5, at around 1.33 gigs total.  I’m MOVING files from my SSD to my WD MyCloud via a 1Gig router.  This is the average rate speed I’m getting.  This is getting ridiculous.  Please give us another FW update to un-do what has been done to cause such horrible speeds!

Do I need to record a youtube video showing this?  I feel really bad for the people who are just now buying this product only to find out they’re not getting what was promised to them on the box.


JollyAustin,  are you *CERTAIN* that your PC is not simultaneously connected via WiFi (as well as wired)?  You can tell by issuing the command

ipconfig /all | findstr “IPv4”

in a CMD window on your PC.  If more than one entry is listed, then something is probably amiss.

What were your transfer speeds like before the update?

So far (and this of course is just in passing) – all the folks reporting slower speeds after the update were having slowish speeds before, too…

Here’s some very technical things to look at, too:

See if this gets your anywhere…

I’m one of those folks whose speeds increased quite a bit after the 4.x update – From my Win 7 desktop, I can READ large files now at over 100MB/sec consistently.

Even my purposely under-powered VM-based Win7 box can read at over 45MB/second:


Thanks for the reply.

I am certain my PC is not connected via WiFi becuase I didn’t install any wi-fi adapters.  I’m hard-wired.  To give you more background on my setup:

Cable Internet coax cable to my modem > ethernet cable to my router (Asus RT-N65Uwired/wireless) > then an ethernet cable to my PC and an ethernet cable to the MyCloud (using the stock cable, about 1m long).  The only wireless access is via my mobile phone.  That being said, I feel I should be getting no interruptions or slowness at times.

Confirmed only 1 result when using the command you posted.

To be honest Tony, I don’t recall the *exact* speeds, but I would estimate around 45-60mb/s?  I mean it’s almost as if this drive has been capped for whatever reason.  It starts out at around 45mb/s then just drops about 10% each time the numbers update.  I bought that 1gig router for the purpose of getting some good streaming out of this MyCloud to my PC and TV but there is no way at this moment.  I think I can actually put a gif together of this happening, sped up.

As for the technical details, that is a bit overwhelming but I’ll read through it to see if something may help.  Thanks.

I really hope WD finds a fix pretty quick for the users with slow speeds.  It’s weird that it didn’t affect everyone.

I take it back, everything was working fine for a while this morning but now it’s slow as molasses again. So will standby and wait for update or return to previous version if you put it up on the web site. 

But - in case this helps - I noticed that my version of mc_windows_setup.exe was a little older than your most recent. mine is 77mb from 06 mar 2014.

I did not try to reinstall the new version on top of the old (yet)…

Patiently waiting for your help.

Alright I’m back with some benchmarks.  Some background in case anyone asks:

Current internet speedtest (running off an Asus 1gig wired/wirelss router)

Firmware: v04.00.00-607

Alright, so this benchmark will show “Moving” and “Copying” of files back and forth.  I have two runs - a “Single” and a “Multi” run.  The single run is a single file 4.37gb in size.  The multi run is around 50 files totalling 4.37gb in size.   “NAS” means the MyCloud, “SSD” means my local hard drive, and “USB3.0” is my external 3.0 drive.

You will see 10 screencaps - 4 are transfers from the NAS to the SSD, 4 are transfers from the SSD to the NAS, and 2 are baseline transfers from the SSD to my USB3.0 External.

Here are the results:

Copying from NAS to SSD Multi:


Copying from NAS to SSD Single:


Moving from NAS to SSD Multi:


Moving from NAS to SSD Single:


Everything looks good so far!  But going the opposite direction causes serious slowness.

Copying from SSD to NAS Multi:


Copying from SSD to NAS Single:


Moving from SSD to NAS Multi:


Moving from SSD to NAS Single:


And for a comparison, some transfers to my USB 3.0 External:




For whatever reason, I can copy and move files with ease *FROM* my NAS *TO* my SSD.  But I cannot transfer files from my SSD to my NAS at the normal speeds.

Please let me know if anyone else has tried these benchmarks and if you could let me know what speeds you’re getting.  I’ll continue to look around to see if anyone else has this issue.

I seem to have sorted my issues on my own with no help from WD.

I tried a few things suggested elsewhere on the net and after about 5 reboots, transfer speeds have been restored to a level prior to the firmware upgrade!

not a technical solution, but it may work for you

I had the same problem but managed to fix it !!!

open the twonkey interface on port 9000  i.e. wdmycloud.local:9000 go to advance menu and click clear cach then

changed setting in advanced of media re-scan frequncy to 0 instead of -1 .

then go to admin web interace and turn off media DLNA server in settings. then select rebuild database and wait for it to finish.

After that re-enable media DLNA and got to twonkey advanced settings and change the re-scan back to -1 .

now rescan your media and perfomance should be back to normal.