First of all please apologize if my problem has been already solved but I’ve read several messages and still can’t fix my problem.

My MBL is updated with latest firmware with no issues. New user and folders are created: the user can access the folders and these are marked for all multimedia services.

The MBL is recognized with no problem by my PC, iPad, iTunes…but no song is displayed in iTunes (I can play songs using WD2GO with my iPad). I can see the MBL in iTunes, containing the “Reproduction List” folder and “Movies”, “Music” +  “TV Shows” lists…but no song.

I rescanned MBL, iTunes is enabled…don’t know what else can i do. I also copied songs in Public and private folders (testing) but with no results… .

Can somebody help me? Thanks in advance!

Did you check if UPnP is enabled in your router?

1 Like

iTunes doesn’t use UPnP; it uses DAAP/Bonjour.   And you don’t need to enable either one on your router since both devices are on the same side of the router.

I *think* that, to show up on iTunes, the music tracks may need to be in the SHARED MUSIC folder, not folders that have “Media Sharing” turned on.   I think only Twonky uses that particular setting.

1 Like

Thanks mates for your support.

The UpnP is enabled in my router…and it didn’t works.

I made a test copying traks in both shared (Public/Music Shared) and own created media folder…with no success.

Any other idea about how to see the tracks? Did you do anything special in iTunes?


Try rebooting your My Book Live and see if that helps.

Thanks Toni, rebooting was a nice try, but It did not work.

Any other idea?  The MBL seems to be ok (firmware is updated) except for this.

Thank you.

I have had intermittent success in getting the iTunes server to work.  I have updated MBL to the latest version of the firmware, have rebooted the drive and checked the share to ensure that the media server setting is set to all.  I have updated iTunes to the latest version 10.5 and still nothing.  This has been going on since January.  I have about given up on this feature.

Any suggestions.

I rebooted the drive and iTunes showed MBL under as a shared drive.  When I tried to look at the music the iTunes kept trying to read the drive without success.  I finally gave up.  I reboot my computer, relaunched iTunes and the shared drive was gone.  I reboot MBL again restarted iTunes and nothing.  As far as I’m concerned this feature is busted.

I have exactly the same problem! :cry:

And this feature was the main reason for me to buy the my book live!

Very disappointing, especially since it worked with the old firmware!

Hey Smasher, it sounds like you at least had it working consistently before.  I never have and it’s worse on the Macs that I have.  It’s always a hassle to try and figure how to get the Mac to see the drive either in iTunes or on the network.  But that’s more likely an Apple not playing well with others issue.

This seems to be an issue with the latest version of itunes(10.5) I thought I was going crazy trying to make this work, until I tried it on an older machine with itunes version 10.2. The old itunes loaded the shared music perfectly! Hopefully either WD or Apple will release an update to fix this!