Issues updating to new version

So I am runnning into some issues updating to the newly released version. Currently running 3.3.1 156.

Tried running the update through UI and stops at 10% and errors out.

Tried manually downloading the file and starting update through UI - 10% again and fail.

Tried SSH-ing into the device and running the update script and pointing it to the deb file, fails again…

I get the following error extracted from the update.log for each instance of the errors:

Preparing FW upgrade image on: “/dev/md1”

preinst: currentRootDevice=/dev/md0

preinst: upgradePath=/mnt/rootfs

preinst: upgradePart=/dev/sda1

preinst: upgradeDevice=/dev/md1


Unpacking replacement sq …

Unpack timeout occurred

failed 202 “upgrade download failure”

stopping duplicate md device /dev/md1

Anyone have any idea on how I can force the update? Or… how can I reset the Debian OS on the device to 100% stock and then attempt to update…

Note, running the 3TB version.

I do see that it takes FOREVER for dpkg to unpack the rootfs.img file and when it gets to about 1.3-1.5GB it times out…

Managed to take it out of the box and copy the contents of IMG file on the partitions and get it booted.

Now I have the following issue when it boots up and I can’t finish setting it up:

Anybody have any ideas on how to fix this?

Weird, but I can see the picture.

Well, once I get to this page, SSH is disabled, so I can’t get into the device remotely anymore…

File a ticket with WD, if they cannot resove it take it back to where you bought it.

This thread helped me:

Got the image. Used Ubuntu and restored it to the drive. Scanned the ext4 partition - sda4 and extended and we’re back in business! :slight_smile:

This is what I did to fix it:

-load up a live Ubuntu drive and attach the WD drive to the machine.

-download the image from the link above and extract the IMG from there.

-start Disks application and select the WD drive.

-click on the gear and select ‘restore from image’ for the whole drive

-point to the downloaded image

-run fsck on the 4th partition

          -for me, the device was mounted as SDA

          - fsck /dev/sda4

-start GParted and extend the sda4 partition to fill up unused space

-put back in case and boot up :slight_smile:

You now have a fully working drive in ‘just out the box’ condition.