Is my WD My Book Live broken forever?

A couple of days ago I noticed that Time Machine Backups were not taking place.

I found that network connectivity was not available and even ping was not working.

The Status LEDs quit working years ago.

I pulled the plug on the My Book Live to try and reboot ( am running the latest
firmware ). After the reboot when I tried to to start the time machine backup, I received an
error message that said the identity of ‘nas’ had been changed! I told Time Machine to use
the drive anyway and after a bit of thinking it said it could not create the backup file.

I ran the short diagnostic and it told me that the drive diagnostics had failed.

I created a support ticket yesterday but am not hopeful.

Has anyone had a similar experience?

I can see files ok and ssh into the ‘nas’ .

Any suggestions will be appreciated :smile:



A few users have help other creating guides to help users to debrick their unit.

See if the following link helps:

Please note that following those steps on that guide will be at your own risk and it will delete the data on the unit.

if you ran a diagnostic and it failed then most likely your disk drive is bad. i’ve had a lot of bad experience with WD drives both USB and NAS devices constantly failing almost with certainty. The Apple Time Machine backup target requires Apple File Sharing Protocol which is painfully poor performance compared to CIFS/SMB, so that’s a “no-go” as far as using it as a backup target for any substantial amount of data - and eventually it craps out as you found and I found for all sorts of different reasons. For most reliable Mac backups you should go with an Apple Time Capsule, or an external USB drive plugged directly into your Mac. Good luck.