Inconsistent FTP Speeds?

Hello everyone. I just want to start off by saying I am pretty tech savey as far as networking and NAS goes, but maybe someone can find a solution for me? I am actually thinking it is a defective unit by the symptoms.

So I got the My Cloud Ex2 yesterday, formated the drives, allowed FTP, ect.

Started transfering all my files from my backup drive to my Ex2. Speeds are considerably fast as the average is around 60-70Mb/s. However at certain points after around anywhere from 30 minutes to 60 minutes the transfers start to stop and stutter but do continue and speeds start to drop to around 30Mb/s then to 10Mb/s consistantly.

These are all the things I have tried:

1.Tried Sftp(SSH), Ftp, Samba, And even the built in desktop app for windows that WD Offers.

2.Connected the NAS directly to my my PC NIC card with static IP settings and also network speed set at 1000 in both NIC card and within the network settings of the EX2.

3.Enabled Jumbo frame from 9000 all the way down to off on both the PC and the EX2.

4.Do not have any Firewall or Antivirus running in the background.

5.Tried Full Duplex And Half Duplex, as well as Auto Negotiation.

6. Watched the home screen Statistics and the Ram never spikes higher than 52%, CPU spikes very rarely to 100%, but that does not effect the speed at that very moment.

7.Tried a combination of different hard drive to ensure it was not the Cache filling up on the individual drive.

8.Ensured Source drive was defragmented before transfer.

Anyways, thanks in advanced for any help someone can give me. I have recently upgraded to the EX2 from the Goflex Home NAS and I hope I do not have to regret this decision.

Another issue I encountered is the Fan NEVER kicks on even if the drives are at 58c or higher. These are unacceptable

temps for a nice efficient NAS setup. I have however connected a fan for the time being assuming the Firmware will have this at some point? As you can see from the Picture.

IMG_20151005_235640.jpg

Hello and welcome to the WD Community.

What firmware are you running on this unit?

Does resetting the unit makes any difference?

Hello, and thank you for your reply.

I did in fact find out what the issue was. It turned out to be the Cache on my 5TB Drive filling up during large file transfers.

But I do really hope a new Firmware comes out fixing the Fan issue.

One last question. Is there a way to check individual drive capacity?? I noticed on the front page it shows TOTAL available space. But do not see anywhere to view individual drive percentages.

Hi,

Currently, there’s no option to see the individual capacity of the units.