I/O Errors on 4TB Drives

I have now ordered three 4TB Western Digital Black drives and all three have produced I/O errors. The first I was able to format and start to use but it almost immediately shifted to giving an I/O error. The other two produced I/O errors as soon as I tried to initialize them. I am working on the assumption that it’s extremely unlikely that I got three bad drives in a row and that there must be something about my system that is not compatible with the 4TB drives. At the same time I installed a new 1TB WD Black drive and it seems to be doing fine. I am running on Windows 10 (but I first tried to use all three drives on Windows 7 but not as boot drives). My motherboard is an Asus P9D WS. Asus says this board should support 4TB and 4kn drives. I mention 4kn because I’ve wondered if that was the issue. I’m not sure if it matters that when I look in system information I can see the other working internal drives (all WD Black 1TB drives) and all list the bytes/sector as 512. The 4TB drive shows up here too and it also shows as 512 bytes/sector. Should it? Is the 4TB drive supposed to be a native 4kn drive or is it a 512e drive? There’s a working external WD My Passport drive that shows as 4096 bytes/sector but of course that’s connected via USB rather than SATA. I can’t figure out if I should:
A. Try to return the third drive under warranty and hope the replacement works.
B. Bite the bullet and buy a new motherboard and CPU.
C. Look for some other component in my system that might be at fault.

Hi @BruceGH,

Please refer to the article Error: “DISK I/O ERROR”, “INVALID SYSTEM DISK”, or “NO OS FOUND” while trying to boot your Windows computer:
https://support-in.wd.com/app/answers/detail/a_id/22158

Thank you for your response. That article appears to only address I/O and related errors in a boot disk, which as I said in my original question is not how I am attempting to use this drive. The only parts of the answer that would appear to have any applicability to my situation are:

  1. “Another reason could be that the drive capacity is too large for your computer.” The motherboard manufacturer (Asus) says that this is not an issue. I note that this article was written almost 4 years ago, when operating systems that would have problems booting to a >2TB drive were more common.
  2. “you may have a bad cable” I tried multiple cables so I think we can rule this out.

Hi,

I appreciate that you have performed the troubleshooting steps.

Please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Hi,
Most of the device I/O errors can be fixed by checking the loose connection, disk properties, etc. To fix these issues, there could be a variety of options. Before you continue to correct these errors you should first perform the following steps:

  1. Restart your computer/Laptop.
  2. Try to reaccess the drive/device.
  3. If the problem remains the same, then try to access the device/drive data on another Computer/Laptop to confirm that the drive or device is not damaged.
  4. The device input/output error is fixed and you no longer get the error message, you are finished. If the problem remains, then continue with the following solutions.
    For more information you can check out this blog : [Solution]: How to Fix Hard Disk I/O Device Error ?

Thank you Amelia1,

I have restarted and tried different cables so many times I long ago lost count. I would like to try putting the drive into another computer but since this is an internal drive that’s not so easy because I would need to find another desktop PC whose owner does not mind if I open up his/her computer and install a hard drive. I have not been able to find such a computer.

I looked at the page you linked to. Solutions 1, 2 and 3, I’ve already tried. On Solution 2, since this is on a new installation of Windows 10 with all available updates installed it’s unlikely anyway that the drivers in question would be out of date, but I checked to be certain.

Solution 4: I followed the directions to Device Manager, but under “IDE ATA/ATAPI Controllers” there are no individual channels, just “Standard SATA/AHCI controllers” and in the properties for that there’s nothing about transfer mode. I did some research and it seems like this advice applies to now VERY old systems that use IDE rather than SATA.

Solution 5 does not work because I cannot initialize the drive so there’s no way I know of to run chkdsk since there’s no drive letter.

My Bios is set to “native IDE” and so I think it only lets me use 2 hard drives at a time despite having 6 SATA ports.–> I think. Maybe this info will help:

I’m running win10H 64bit with a Gigabyte Ga78lmt motherboard.
I have a 1TB SDD (for windows) a 1TB WDBlue and a 4TB WDBlack. If I have all 3 connected to the computer it doesn’t register the 4TB WDBlack, that is it doesn’t populate in the file explorer. It did for a little bit but when I tried to copy a file to it, the computer did a lot of thinking and then the drive disappeared with a I/O error. (I did all the checking of cables and restarting and check this/check that). If I look at Drive Manager it shows the disk but won’t let me do anything with it. If I try to change the drive letter it says I have to initialize it but then when I say go ahead, it then gives me the I/O error. If I use “WD Dashboard” it shows the 4TB WDBlack but shows it “Locked”. If just the 1TB SDD and 4TB WDBlack are installed it works just fine (so it remains in that state). But I think I need to change the BIOS setting for the “ONCHIP SATA TYPE” to AHCI (Currently set to Native IDE) which is limiting the system to just using two hard drives per the IDE settings its emulating.

As I understand, to change your BIOS to AHCI isn’t that simple and some registry changes need to happen unless you have it selected like that before you install windows.

Not sure if that’s your issue, but it was similar to mine. I’m running win10H 64bit with a Gigabyte Ga78lmt motherboard.

Good Luck-

Thank you RobertM1. I’ve been running four 1TB drives for a number of years now without any issues so I don’t think this is my problem. After all the problems I was having with WD drives I decided to try a 4TB drive by another manufacturer and it’s been working fine so far.


UPDATE for this: I was getting I/O errors, until I limited my drive to just the two like it said above, but I couldn’t save anything to the 4TBWDBlack or add a new file or folders. So the info in my original post isn’t accurate, and after doing below, I can now run all 3 of my Hard drives without any BIOS changes-

I paired the HD with the original Windows HDD I used to format it with (NON_SDD), reformatted the 4TBWDBlack, and then connected the 4TBWDBlack with my current windowsSDD (and removed the windowsHDD). The 4TBdrive didn’t register in Disk Management as initialized. I found this drive to be write protected. I did the steps of the youtube video *seebelow to un-write protect it and its been working great so far.

I didn’t do anything with my BIOS (AHCI/IDE) and connected my 3rd drive (1TB WDblue) and I am currently running all 3 (1TBWDBlueSDD/4TBWDBlackHDD/1TBWDBlueHDD) just fine. I just wanted to update this post because I thought I was helping, but I later found it wasn’t good information as the bios setting (AHCI/IDE) I was referring to clearly doesn’t affect the number of drives.

…and today I sent the drive back. Worked with WD support and it is defective. Thought for sure it was good to go for a bit there.