WD Black 4TB not working

It already worked once, but then after a reboot the WD Black 4TB (brand new) doesn’t show up in the explorer and the Status is “Blocked”. I cant initialize it in disk-partitioner, E-A Device Error.

But it shows up in Device-Manager aswell as Disk-Partitioner.

I am using an Asus Prime Deluxe II X299 Motherboard and my old WD Green (caviar?) 1 TB is working fine.

Edit: it already worked and i used it as my Library for around ~2hours until i rebooted and all was gone again… this is really driving me nuts

Edit 2: It also doesn’t work on another SATA Plug. While the other HDD (Green/Caviar?) works on both

Edit 3: Reattaching the drive & enabling “Hot plug” in BIOS seemed to work. this makes no sense to me?

Edit 4: Restarted again and the drive is not visible anymore

Edit 5: The drive is not recognized at boot time / when clicking around in Windows 10, but when it (Hot) Replug it, it’s suddenly in my Explorer?

Whenever there is “ disk unknown not initialized” issue occurs, your hard drive may show unallocated space in Disk Management, and the data on which will be inaccessible or else there is another situation: there is no disk space shown in Disk Management.

Below are the 2 different methods to resolve the issue:

Method 1. Use Disk Management to fix not initialized error on an external hard drive

  1. Connect the uninitialized external hard drive to your PC.
  2. Press Win + R keys, type: diskmgmt.msc and hit Enter.
  3. Find the uninitialized, unknown external hard drive with I/O device error > Right-click on it and select Initialize Disk.
  4. Then set the disk to initialize and set the disk as MBR or GPT.

After this, you may reboot your PC and keep all changes. Now, your external hard drive will be recognized and read by Windows again.

Method 2. Run CMD to repair I/O device error on not initialized external hard drive

This CMD command would erase all data on the uninitialized hard drive, which you can later restore after repairing the external hard drive not initialized, with the help of any data recovery or partition recovery software:

  1. Press Win+R > Type: diskpart and hit Enter.
  2. Type: list disk and hit Enter.
  3. Type: select disk F and hit Enter; (replace F with the drive letter of an uninitialized external hard drive) .
  4. Type: clean and hit Enter.
  5. Type: convert gpt or convert mbr and hit Enter.
  6. Type: create partition primary and hit Enter.
  7. Type: format quick fs=ntfs and hit Enter.
  8. Type: assign and hit Enter.
  9. Type: exit and hit Enter.

Hope it will help you resolve the issue.

It’s not about an external Harddrive, it’s an internal HDD

  • When booting it shows up in RST (for Raid optionalities, im not using that though)

  • It doesn’t show up in BIOS (ASUS Prime Deluxe II x299 Motherboard)

  • It doesn’t show up in Windows

  • When i replug it on running Windows, it shows up and is 100% functional.

  • When i restart it goes missing again in BIOS / Windows

I tried switching the SATA-Plugs but it doesnt make a difference.

My 3 SSD’s and 2nd HDD (WD Caviar?/Green?) are working fine/as expected.


its showing up here as “Blocked”

And not showing up in device manager.
image

Could be the disk is dead, i assume the PSU has enough power too

check data and power cables

I bought a WD Gold and WD Black 4TB, both have the same problems. It only shows up when i hot-plug it on a running System, when i start my system and dont touch it, it doesnt show up…

PSU is 1200W, Chcked all Cables, yes. :frowning:

Try the 4TB disk on another machine, if it works then copy it to another disk

It’s not about saving data here, the disk is brand new and i want to use it in my new computer - i already tested them on another machine and they are working 100% there. :frowning: if i’m not able to make it work i’ll probably just buy a NAS, put them in a RAID 1 (or whatever the redundancy RAID is) and use the NAS… i’ve given up at getting them to work in this specific PC. this PC cost me 5000$ (with monitors) and has a new ASUS Prime Deluxe X299-II Motherboard etc etc.

The synology 8 disk NAS is popular