4TB drives keep getting corrupted - anyone else?

OK, I’m having some trouble with 4TB drives. I have had VERY reliable function with my previous 1-TB and 2-TB drives (both “My Passport” style). I purchased a My Passport Metal Ultra 4-TB drive, and nothing but trouble.

Have had a host of problems:

  1. Computer thinks drive needs to be formatted. (Fixed using CMD prompt, chkdsk utility.)
  2. Computer detects errors, wants to run CheckDisk. (Usually fixes the problem)
  3. Folders or files go missing, or are unable to be opened (Usually CheckDisk fixes this problem, too.)
  4. Permissions denied (found a complicated fix for this also)

I’ve been able to run a fix and save nearly all my data every time this happens, but I’m spending a whole lot of time trying to “fix” the disk, that it is driving me crazy.

Before you suggest “safe eject”, powering down, and gentle handling…YES, I’m doing all these things. The drive has about 3 TB of data on it (not over-full). I always do “safe eject”. I have even taken to “shutting down” the laptop before disconnecting the drive. Of course, with these 4TB drives, the power light seems to blink interminably even when laptop is off–I tend to disconnect the drive when the blinking light is “off”. The drive does go with me to work (in a carefully-handled briefcase); I don’t drop it or throw it around.

I thought I’d try a different model, so just purchased the 4-TB “My Passport” version (not the metal/ultra one). Got all my data transferred last night. Went to work today. Plugged in the drive. Seemed to work OK, but then I noticed 75% of my folders were absent, and others could not be opened. Ran checkdisk, and now all is well again. WHY DOES THIS KEEP HAPPENING?

Happy to hear any and all advice. So far, seems to me a 4-TB drive just cannot work for me.
FYI, I’m using an HP laptop running Windows 7 Enterprise.

Thanks,
sch

Hello,

I recommend you run a diagnostic using WD DLG to determine the drive’s health.

Data Lifeguard Diagnostic for Windows

I have done this before – did not correct the problem long-term. Will try again and continue to monitor. I hope if I get fed up with these drives I can take advantage of the warranty.

I too am experiencing this exact same issue. I am ready to return the product.

Can WD help?

I have gotten no response from them. One of my drives was still within the return period, so it went back to Target (cut my losses). The other I bought online months ago, and I am not sure I can get my money back. I may try to see if it is under warranty, but I suspect a replacement drive would have the same problem, since it seems to be present in both 4TB drives from different product lines. Frustrating, to be sure.

Steve,

Thanks for the info. This is the first drive I have that has this wonky issue. You would that this level of technology maturity that this type of failure is not possible, but oh well.

So you are having the same issue on multiple 4TB drives?

Thanks,
Hai

Yes—I tried these two:

My Passport: https://www.wdc.com/products/portable-storage/my-passport.html#WDBYFT0040BBK-WESN
My Passport Ultra Metal: https://www.wdc.com/products/portable-storage/my-passport-ultra-metal.html#WDBEZW0040BSL-NESN

Both having the same trouble.
I figure—for some reason—my laptop/operating system just cannot keep up with this size drive. Must be some systematic errors in writing/saving data that leads to corruption all the time. I’ll stick with 1- and 2-TB drives for now—have had no issues with them.

sch

I have the same drives as you do. I did run into the same issue with the regular passport, but it might be because I am only using it as a backup drive. The metal is the one that I use daily and basically, work from.

This is no good because I needed a large drive that is encrypted.

[Update]

The new 4TB Ultra metal worked for 1 week. I have not used it until this week and it’s failed already. Disk structure is corrupted and unreadable error.

It’s WD whole metal line cr4p? 2 for 2 dead? QA at all?

I use my 4TB metal drive only for backups now. Seems to be reliable for occasional use, but not daily use as my main drive.

I don’t know what else to use. I wonder if I should order another 4TB in silver (the two I had were blue). Third time is a charm maybe?

I have same issues with 3 and 4 TB drives. Data keeps getting corrupted. I have three different WD 3 and 4TB my passport drives all of them act same way they work fine for few weeks then when I try to open them in my computer I get error that drive inaccessible in windows. why is that ? Even though the WD utilities see it, I enter password to unlock, the windows recognize the drive in my computer, in windows disk management see the partition with no issues. I also ran the WD diagnostics the 2 min and the extended all pass fine. I tried different laptops, USB cables etc.
There must be something that causes this behavior which is repetitive, I have formatted the drives several times , copy data on to them use for few weeks then back to same inaccessible problem. I need this resolved ASAP. I update to Firmware 4.0.1.4 but still same issues.

Hi,
I’m also having this same issue with my My Passport Ultra 4TB, the drive will work for some time then all of a sudden, it becomes Unallocated ? it’s also difficult to format the drive once this happens.

There must be something wrong with the drive, maybe there are all defective ???

I have sent a message to WD, lets see what they come back with ?
Thanks

I’ve made a point of only connecting 2 drives at any one time, and always hooking up the 4TB drive with a USB-C connector. So far I have avoided this error…but I’m not using the drive as often as I used to!