I dont have acetrax movies or iplayer on latest firmware 1.12.14

i hope this is the right forum to post, this site is extremely confusing to navigate.

i bought the WD TV Live Streaming Media Player yesterday and set it up the same day.

it instantly asked, and i allowed it, whether to upgrade to firmware 1.12.14.

i was checking the different options but couldn’t find iplayer or acetrax movie (there is an acetrax movie ticket book within the Player box, so i presume i should have it.)

what i’ve tried so far

did a full factory reset.

set Time & Country to London

i reset location to united kingdom

There is something wrong with WD’s location service. I have reset the location on my player to check out your problem and now I am missing iPlayer and acetrax.

Aah sorry to hear your now missing these options!
Personally, I cannot be sure i ever had them. First thing i did was download the latest firmware and they were missing. I reset the location to united kingdom and it’s still not there.
I’m sure it was already set as United Kingdom as it always says it’s 'changed ’ it even if I set to United Kingdom multiple times

I also have this problem with a new unit which has just been installed and during installation firmware was updated. Other units are ok.

It only happens if you reset the location or reset the player.

Im glad I’m not the only one to be having problems! It hopefully means it’s not an issue caused by my own stupidity :slight_smile:

It may be OK tomorrow if WD pulls their finger out. Try resetting the location then.

@richuk, or, presumably, when the box does its initial setup? It must be attempting to find its location then as well

Thanks for the responses. I’ll definitely give that a try, richuk :slight_smile:

Yes it does it then because a new player is a reset state.

Hi I am getting the same problem no BBc iplayer I contacted the WD support phone number and they did call me back within 30 minutes and they advised a factory reset. I tried that today and it is still the same using 1:12:14 firmware and in the UK using the WDLive TV Streaming device.


Thanks for any help

We are still waiting for WD to mend their location server which tells the player which services to show. Anybody in the UK who resets their location or resets the player will lose UK services such as iPlayer. As has been said this also affects those users with new players as they are in reset state. Hopefully WD will get it working soon if they know what’s gone wrong!

Hi there,

I also have the same problem!!

Have I got to do anything on my WD TV Live or Will BBC iPlayer just appear once WD fix this there end? 

Same issue, very confusing. New box, set up over the weekend. No sign of iplayer or acetrax. Hope this gets sorted soon … not very confidence building.

Same issue here too. Got my WDTV Live SMP on Saturday, no AceTrax or iPlayer. Not a very good first impression

Think i’ll have a go at calling tech support.

Same for me too - purchased over weekend and setup to find no iPlayer or Acetrax. Iplayer was one of the main reasons I purchased the box so it’s critical this issue is sorted asap. Any update from WD themeselves?

Well I called WD support several times - all of the fixes they advised me to follow did not resolve the issue. A ticket has now been raised to technical support.

No idea when this will be fixed, it would probably be a good idea for you to ring them too. The more calls they receive they receive about this issue - the quicker it’ll be fixed…

WD support responded to my ticket instructing me to undertake the steps others have outlined on here. Reluctant to waste my time doing them if the steps haven’t worked for everyone else.

Disappointed for the response not to have been more personalised or to have recognised a common issue that seems to lie with WD themselves. 

May try the steps this evening but I’m not holding my breath. Disappointing customer support.

Try to do the steps if possible and report back. At least you can say if they work or not from experience. I have just done a reset again (I have done many over the last few days) and the services for the UK are still missing.

Yes, I agree. Everybody who is having this issue needs to ring and get it logged as it will put some pressure on them to sort it out.