I can't access my cloud from my network anymore

#1

I haven’t changed anything except updated a new version of WD software. I can still access remotely through, but I can’t access in my network folder like I used to.

What should I do?

#2

How are you trying to access via Windows FIle Explorer perhaps?

#3

If you mean the network folder one sees in WIndows FIle Explorer, all you may need to do is refresh that folder, so highlight Network, and refresh the screen depending upon which version of windows you are using by either the curved arrow or opposing arrows in upper top area of screen.

#4

Hi mike27oct,

I think we’re referring to the same thing- windows file. I refreshed it
but I still don’t see my cloud.

Any other suggestions?

#5

I’ve got to go, so quickly:

Reboot your windows PC
If that doesn’t work, reboot (actually, reset) My Cloud (check My Cloud manual for how to do)
Write back if none of this works for you.
Later.

#6

go into settings and under windows update see if there are updates to your windows 10. Micrososoft has released a network discovery fix.

#7

Ensure both the My Cloud and your computer have the latest updates.

If using Windows 10 there are known issues with the Windows 10 November update with the My Cloud including the My Cloud not showing up properly under Windows File Explorer. Microsoft released a Windows 10 Update this past Tuesday (March 1, 2016) that appears to fix the My Cloud / Windows 10 File Explorer issue.

https://community.wd.com/t/windows-10-kb-3140743-possible-fix-for-my-cloud-issue/153567

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#8

I have rebooted mycloud and its still not working.

I am actually using Windows 8 so this update shouldn’ t affect me right?

#9

Hi again. So, my rebooting advice didn’t help? Hmmm.

No, Win 10 updates are irrelevant for you. I have a Win 7 and Win 8 PC, and the My Cloud seen on my Win 8 shows in Windows/File Explorer view in both Computers and sections. Do you see it in either place on your PC?

If you rebooted your PC and the My Cloud, then reboot your router. I think somehow the IP address of one of the devices disappeared, and rebooting router can help refresh and reassign all IP addresses. If doing this doesn’t help, then a reboot of the PC and My Cloud should get the IP info straightened out for them, since all are rebooted in a logical order.

1 Like
#10

Windows 8 was not affected by the Windows 10 CIF/Samba issue that some of us experienced with the My Cloud.

Is the My Cloud Dashboard accessible via a web browser? If so is it by the My Cloud name or by it’s IP address?

Other things to check or try:
Ensure Network and file discovery is enabled on Windows 8.
Make sure your network location is set to Private, if not it won’t discover other local devices like the My Cloud on the local network.
Configure, if you haven’t done so already, the My Cloud for a Static IP Address either through the router’s DHCP server (consult the router’s documentation) or through the My Cloud Dashboard.
Input the My Cloud IP address into the address bar for Windows File Explorer (for example: \\192.168.1.2) to see if the My Cloud can be reach directly with Windows File Explorer.

#11

I would like to add. After installing the latest upgrade from Mar 1. I started getting a message that “these files may be harmful to your computer” when moving a file from one folder to another folder on my NAS. Also my Powershell scripts started asking me to run only script that I trusted. It wanted me to use the UnBlock-File cmdlet which didn’t allow the scripts to run. I found at the web site below how to fix the problem.
http://superuser.com/questions/149056/disable-these-files-might-be-harmful-to-your-computer-warning

RAC
PS Since this update all of my network devices show up in file explorer like they should. Except one device no longer shows up on the left under network. But I can map the device and access the files.

#12

Thank you so much for all your help! I can see it again =)

#13

OK, so what suggestion(s) fixed it?

#15

So frustrating as I’ve spent an entire day trying to figure out how to access the MyCloud device through Windows Explorer on Windows 7 Pro.

I rebooted the router, only the router. And it was like magic! I can move folders within Windows explorer again. Hope this helps someone else.

1 Like