Huge problem using FTP with my WD 3 TB Live NAS

Hi

I simply can´t get the FTP part to work with my nas. (everything else works fine)…

I have set “FTP Enable” in the UI.

I have made a port forwarding, not quite sure if this is right, but this is how it looks:

In the UI of the Nas:

Configure settings for remote access to your My Book Live.

Remote Access:
Enable

Connection Status:Connected 

Port forwarding connection established.

Connection Options:
Manual                               Windows XP compatibility                          Manual

                              Automatic                             
Application Description External Port   Internal Port   Protocol   IP Address (My Book Live)
WD 2go Port 1:* 8080 80 192.168.2.187   
WD 2go Port 2:* 8443 443 192.168.2.187   

In my Router:

Port Forwarding Enabled

rule name

 

MBL80

MBL443

LAN IP

 

192.168.2.187

192.168.2.187

PROTOCOL

 

TCP

TCP

LAN PORT

 

80

443

WAN PORT

 

8080

8443

     

When I try to use FTP (with cuteftp), I use:

Host: wd2go.com

User: admin (default in UI)

password: the one I created in the UI of the Nas.

I am not even sure what I should put in the Port field when I try to connect.

Sometimes it says:

Socket connected, waiting for welcome message…  but then nothing more happens…

Really hope I can get some help with this, going Crazy (on day 3 now)…

Best Regards

Henrik

You can’t get it to work because what you’re doing isn’t even close.

WD 2go isn’t an FTP server, so of course that’s not going to work.

Likewise, FTP has nothing to do with Remote Access settings.

ok, but is it possible at all to get it to work with ftp ?

If you want FTP, all you have to do is enable it, or read the manual! :smiley:

But seriously, read the manual. Always read the manual as your first option. If you do not get it from there, then let us know.