Set up for ftp

I own a my book life and want to set it up for FTP. A few questions about that:

  1. What is FTP exactly and what are the advanttages using it?

  2. How can I set up my device for FTP?

Hope that this will be the start of a interesting discussion!


so much for your interesting discussion … :slight_smile:

FTP is just for transfering files. A low overhead File Transfer Protocol.

If you don’t need to use it, might as well not.

In order to enable it, go to the UI, then System, then Network. There is an option under that tab to enable it.

You must have a user with a Password in order for an FTP client to connect to it.

Haha, thanks

I will read the links but it is not entirely clear what the advantages are using FTP. I thought it was easier or faster up- and downloading files to the NAS?!

Next question concerns the device itself. I tried install it at my parents home but the light on the front of the device was always red. I tried multiple times but it always turns red. Same story for my own home, also a red light… Then i tried installing it on an other addres and there the light became green.

I think i can conclude the device is working since it became green on one of the adresses. Am I correct? The strange thing is why does it not work on the other adresses? Is it possible the NAS does not work together whith all routers?

Then the next problem. I have my device on the adres where the light became green, but when i trie to acces it through i dont get acces? Any thoughts aboout what could be wrong?"?

The light can turn red for a few different reasons, like drive failure/drive overheading/no network.

Since it works at one place, I would assume it cannot connect to the network at the other places. I don’t know if there are known problems with certain routers, perhaps someone else does…

Have you setup from the user interface on the device? If so, try setting it up again on the network you are using now.

Also, I have had problems accessing a drive using if my computer is on the same network as the drive. It will work fine from remote networks, but not from the same.


what do you mean by this?

Have you setup from the user interface on the device? If so, try setting it up again on the network you are using now.

I dont know what you mean so maibe you can explain this?

I have now problems if i am on the same network as the device, i do have problems when i am on an other network. The opposite of your problem i think:p

Hey again. Lets see…

Setting up WD2go should give you access from outside networks.

  1. Go to the MBL’s admin page. Should be something like http://mybooklive or on an Apple http://mybooklive.local .

  2. From there go to Settings, then Remote Access. I think that there is an option called Web Access from that point.

  3. Put in your email address and it will send you a link to setup a password to access your MBL.

Good luck

how do you access your fileds by FTP after enabling the FTP option from dashboard.

You need an FTP client, like FileZilla… of you could try using your web browser by replacing http:// with ftp://mybooklive