FTP Access and port forwarding

Hi

I am trying to set up FTP access and I believe I need to setup port forwarding on my router (Belkin F9J1102 v1) as I am getting a connection refused error (not due to login credentials).  I have followed the instructions at  http://wdc.custhelp.com/app/answers/detail/a_id/8526/~/how-to-enable-port-forwarding-on-a-network-router-for-use-with-a-my-book-live however I am getting the “port forwarding failed to connect on port 80 and 443 error 31526” error.  This is my setup on the Virtual Servers page of my router…

Description   NASMovies1

Inbound port 80

Type BOTH

Private IP address 192.168.2.25

Private port 80

Description  NASMovies2

Inbound port 443

Type BOTH

Private IP address 192.168.2.25

Private port 443

Any help is appreciated.

Hi,

The URL of the port forwarding is meant for WD2GO setup (which use HTTP & HTTPS), not FTP port.

For FTP, what you need to do is to port-forward 20 & 21 at your router, you can refer this URL for port number: http://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers

Something like (you may change the inbound port, but the FTP client will need to use the port when connecting):

Description NASFTP1
Inbound port 20
Type TCP
Private IP address 192.168.2.25
Private port 20

Description NASFTP2
Inbound port 21
Type TCP
Private IP address 192.168.2.25
Private port 21

Hope this help.

Note:  You may need to use any Dynamic DNS (like DynDNS, No-IP) to associate to your Public IP.

Click the Kudos star to say thank you for helpful posts and be sure to come back and ‘Accept as Solution’ under options for the post that solved your issue.

Jimmy

I’m also having this issue (error 31526), and also did port forwarding from 20 to 20 and 21 to 21 and still unable to connect via FTP (using my external IP). 

Here is my port forwarding config:

External Port Internal Port Protocol To IP Address Enabled
 20  20 Both 192.168.1.100
 21  21 Both 192.168.1.100

And here is a record from DHCP “already reserved clients” table to be sure that I’m forwarding to a correct IP

Client Name Assign IP Address To This MAC Address MAC Address
MyBookLive 192.168.1.100    

 Anything else you may suggest? Any other info you need to troubleshoot?

I figured this out for me. The main problem was that I was trying to enable FTP not where it should be enabled. After I checked “Allow FTP” @ Settings -> Network -> FTP - it worked for me. There is one thing you should pay attention to: first check if FTP working using your local IP (192.168…) - in my case I was unable to connect to the drive through FTP using my actual IP from my network, but had no any issues connecting from outside of my network, e.g. from Android Phone on data, not on WiFi.