FTP problems

Hi everyone

I’m trying to set up the FTP server on my MBL Duo. I am not able to access the server remotely, i.e… outside my local network. I need help, even after having read many similar posts and tried many of the potential solutions stated by other community members, all with no luck.

An overview of my current setup.

  • FTP functionality is, of course, turned on.

  • I have a generic modem, from my ISP, which is connected to my Airport Extreme router (AE). The AE is the DHCP client. My MBL duo is connected to the AE by ethernet cable.

  • My ISP is NOT blocking any ports.

  • I have port forwarded port 21 on my AE.

( On a similar note I have also forwarded  port 80 and 443 for the WD2GO remote access, and this is working fine)

I have associated port 21 with the INTERNAL IP of the MBL duo, which is in my case. The MBL duo’s IP is static. This was done by changing ‘network mode’, under settings, to static, instead of DHCP.

I can access my drive perfectly fine WITHIN my LAN with the ftp protocols of different programs, such as filezilla. I can access my drive remotely through wd2go, where the staus is " port forwarding connection established". So those ports seem to be forwarded correctly. I cannot, however, remotely access the drive through FTP. (tried with different internet browsers and filezilla). I am not even seeing a page to enter any passcodes etc. It just doesn’t connect.

Can anyone see what the fault(s) might be?

Thanks in advance.


FTP and WD2go do not use the same protocols or ports. This means that they can work independently without affecting or correlating to the other service/protocol.

What happens if you manually try to access the FTP protocol from a web browser? And are you able to access other FTP servers on your home network apart from the WD My Book Live Duo? This is to confirm if the issue is network-centric as opposed to device-centric.

Gabara,   don’t be offended if these sound like dumb questions, but:

  1-  When you’re OUTSIDE your network, what IP address are you trying to connect to?    Are you using Dynamic DNS, or do you have a static EXTERNAL address?

  2-  What happens if you try to TELNET to the FTP server?    If forwarding (and the server) are working, then you should see the FTP server’s banner;  something like this:

/home/tony> telnet 21
Connected to
Escape character is '^]'.
220 You probably don't want to be here... Go away.

530 Please login with USER and PASS.

The IP addresses and output will be different on your MBL; I’m just using the above as an illustration.

If #2 doesn’t work, that’s pretty clear indication that there’s an air-gap somewhere.

Thank You both for the replies.

I am no tech savvy ( at all ), and will not be offended by any type of help I get. Every bit of help is appreciated greatly.

Regarding wd2go vs ftp: I was merely stating that port forwarding the wd2go ports was successful, and that I had used the exact same method to forward port 21. I know they are different as such.

I have set up a filezilla server on my home pc, also using port 21, to test the network itself. When I use a ftp program remotely  ( filezilla for example ) I use my external ip ( pc’s ip, obtained from ipconfig command ) address to access my home pc. This is working fine, so I’m guessing it isn’t a problem on my network side?

When trying to access my WD duo i have tried using this same external IP, and it didn’t work. Do I need some sort of service to provide me with an static ip that I can use to connect to? Is this what You mean by what type of ip address I’m using to connect to, Tony?

Tony, I’m sorry, but I don’t know what TELNET is, so I haven’t been able to test it. Is it some built in program/command in windows? (using win 8 ).

I know this will end wih some relatively simple solution. I just don’t have the required ‘networking’ know-how I guess…



Gabara wrote:

When I use a ftp program remotely  ( filezilla for example ) I use my external ip ( pc’s ip, obtained from ipconfig command ) address to access my home pc. This is working fine,

I don’t know how that could be possible.

ipconfig tells you your PC’s address, yes, but that is NOT your external address.  The external address is whatever your router is using facing the internet.

What I meant was i use my external ip, obtained from whatsmyip web site for example. I edited my original post and forgot to change that part.

In any case, should I be using a different external ip when I’m trying to access the NAS?

No, that’d be the right address… 

Okay. I thought maybe I needed some service to provide me with an static IP, but I guess that’s not needed with the WD Duo, since it has the built in FTP server?
I have set the network type to static IP instead of DHCP under settings of the NAS itself, so the port forwarding should always link any external requests to the same ip, being the NAS unit.

I have no idea why this isn’t working at this point.

Any other potential tips?
What about that TELNET test, how do I do that?

Gabara wrote:
What about that TELNET test, how do I do that?

Just like I show above.

After researching the subject TELNET I finally got it to work. I CAN connect to my NAS, i get the welcoming message. But I have only tried this on my local PC, within my LAN. Do I need to try this remotely too ?

Yep…  That verifies that the Duo is working.   If it doesn’t work remotely, then that verifies that your port forwarding is NOT working.