Unable to Connect using FTP


I am trying to set my MBL 1TB NAS for access via FTP. I have followed the various guides online, but I still get a “ECONNREFUSED - Connection refused by server” error. The VSFTP service is running, and the “Allow FTP” tickbox is ticked.

I have setup a designated share for the new user I have created (adding to the security of my NAS), but when I try and connect through Filezilla, I get the above error. My ISP doesnt allow connections using port 21, so on my router, I have the following rule setup (using port 8021 instead of 21):

Internet > 8021 > Router > 21 > NAS

I still cant get things working. Any ideas?



I have just tried chaning the /etc/vsftpd.conf to listen on 8021 instead of 21, and updated the port forwarding on my router but still no joy!

I am trying to connect to the FTP from within my wifi, but using the external IP address as the host. 

first try within the home network with default settings (tcp 21)see if it works. If it does, then try from internet and also do TCP port 20 (besides 21, both ports).

When trying from internet, do not attempt from the same home network, that will not work.

Last FTP is not a secure protocol, in case you are transferring sensitive data.