How to revert back to OS3 from OS5 for MyCloud Gen2

1 week ago, i upgraded MyCloud Gen2 to OS5. I have 3 of it actually. 1st one upgraded without issue. Indexing also completed by end of the day.

So i go ahead with the 2nd one and that is when i regretted doing it. Indexing never finish and the box seem hang. Only ping responded. To access the dashboard, i have to force power off/on but it hang again shortly. The only way to get it to work is to disable the cloud access. That’s stupid!!! IT IS NOT UPGRADE!

Hence i started to explore downgrading OS5 back to OS3 and has managed to do it successfully using steps to recover/unbrick the box. Hurray!!!

I would like to contribute and share my findings to payback to the community for the solutions i obtain for others who share unselfishly too.

Disclaimer : Do it at your own risk! Make sure you know what you are doing and i shall not be responsible if you brick your box.

Share drives will still be there after the downgrade. You will need to redo the initial setup including adding users and setting the rights again.

Here is how to do it.

Things you will need:

  1. Working MyCloud OS5 with cloud access disabled if it is hanging your connection.
  2. Enabled SSH and able to ssh into your box.
  3. Able to copy files into the box or your share drive.
  4. Enable DHCP (default usually unless you set to static IP)
  5. Download these files:
    → OS3 firmware (xxx.bin)
    WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links
    → usbrecovery.tar.gz (unzip into your computer)

Once you have all the above,

  1. ssh into your box
  2. copy the 2 files (uImage-wdrecovery & uRamdisk-wdrecovery) to your MyCloud directory “/boot/boot/” where you will also find ulmage and uRamdisk in it.
  3. Change directory to “/boot/boot/” and perform following commands to overwrite the existing ulmage and uRamdisk.

    mv uImage-wdrecovery uImage
    mv uRamdisk-wdrecovery uRamdisk

  4. Reboot after that.

    reboot -f

  5. After reboot device, use the old IP address and accessable via Web-GUI (Safe mode). Upload the original os3 firmware (.bin file) you download earlier here.
    It will reboot after upload successfully.
  6. Reload the Web-Gui to get to the known WD dashboard and start the initial setup process ‘first steps’ (accept license, set password for admin and so on)

** In case when it did not start the initial setup process but goes straight to the login screen as above, you may apply the 4Secs rule to reset the password. (This happen to me in one of my set)

How-To => How to Reset a My Cloud (single bay) Device

That’s it. You are back in business !!!

I believe the above steps will be similar for other models of Single-Bay MyCloud. So bros/sis who own other model can try the steps and update if it is relavant to their models.


I will try to do it.
I have a MY CLOUD single bay 3TB that was updated to OS5 and the hdd does not stop working as with the previous version.

Thank you so much.
I could go back to firm 2.41.116 and the hdd went to sleep.
Can’t install apps like with os5, but I’ll do it another way.

I couldn’t do it with Putty, and I did it with WinSCP from Windows 10.

Again…thank you so much.

1 Like

No problem. Glad I have help another brother here.

I wish I’d seen this thread when I searched for downgrade. Had no end of SMB access issues with OS5.

I’ve had to go the long winded route of trying to manually recreate partitions in Linux and use the recovery files that way. On the third attempt, made my way back into the recovery UI where it’s currently sat at 0% so hopefully it progresses.

bonjour et merci pour ces infos.
le mot de passe SSH ne fonctionne pas,
c’est un PR4100 que je dois modifier.
mot de passe: welc0me ne fonctionne pas, il y aurai t’il un autre?

The directions posted above are for a different My Cloud unit, the single bay/single drive second generation My Cloud.

Because you are using the PR4100 you may want to see the dedicated OS5 subforum for your device.

OS 5 Pro Series

For example there is the following thread in that subforum.

Revert My Cloud OS5 Back to OS3 (PR4100 & PR2100)

Generally for the multi bay My Cloud models one creates or sets the SSH password when one enables SSH via the My Cloud Dashboard > Settings > Network > SSH.

OS 5 Online User Manual

Select this option to securely access your personal cloud and perform command-line operations via the Secured Shell (SSH) protocol. SSH is disabled by default. Use the toggle button to turn ON or OFF.

  1. To enable SSH, click the toggle button to ON .
  2. Review the SSH message, select the I accept check box, and click OK .
    WARNING! Please note that modifying or attempting to modify this device outside the normal operation of the product voids your WD warranty. * Create a password, and click Save .

Note : The SSH login User Name is sshd .

OS3 How to Access a My Cloud Using SSH (Secure Shell)

OS3 How to enable SSH (Secure Shell) on a My Cloud PR4100

I tried this on my 2nd gen MyCloud,
I wasn’t able to login after a 4 second reset and it picked up a different IP address for some reason.
I ended up having to do a 40 second reset to get it to work,
but other than that this guide worked perfect.

A few tips to make this a fully comprehensive guide:

  • SSH can be enabled in the online dashboard under settings > network (it’s recommended to turn it off again once you’re done)
  • You can use SCP to transfer the files to the MyCloud (I used WinSCP)

I’m not seeing any /boot/boot directory. Any suggestions? I’m SSHd in as root. Just need to know where to put those files. Thanks for the help!

Do you have a second gen single bay My Cloud? This discussion and the directions posted in the first post of this discussion were for rolling back a second gen single bay My Cloud to OS3. It may not work on multi bay My Cloud models.

For example if one has a PR Series device, they should see the first post’s directions in the following link. As always one proceeds at their own risk!!!

Note: For some reason the user who made that previous post on rolling back the PR series removed their post information from the earlier posted WD community support link, but it is still available on the Way Back Machine.