Revert My Cloud OS5 Back to OS3 (PR4100 & PR2100)

Many people have upgraded to My Cloud OS5, only to discover that it’s not suitable for their needs. WD claims that OS5 can’t be reverted, but that’s simply not true.

The “Safe Mode” firmware appears to be unchanged by OS5, so reverting back to OS3 can be accomplished by deleting the Linux kernel and system configuration files to trigger “Safe Mode” after rebooting the NAS. Deleting the Linux kernel may sound scary, but it’s exactly what the firmware does to trigger “Safe Mode” if it detects a problem.

An SSH connection is required, and this specific process of reverting back to OS3 only works on the PR4100 and PR2100. It should NOT be attempted on any other NAS model. I’ve personally tested it on the PR4100, but I don’t use the cloud-based services, so I don’t know how they might be affected.

USE AT YOUR OWN RISK.

The processs of reverting back to OS3 causes all users except “admin” to be lost, in addition to all system settings. Shares and data should remain unaffected. If the OS3 system configuration settings were saved to a file prior to upgrading to OS5, it should be possible to restore them via the dashboard.

Settings / Utilities / System Configuration / Import File

Create backups of your data, enable SSH access from the dashboard, then shut down the NAS and remove all hard drives, being certain to label each drive so it can be reinserted in the same bay it came from. This done as a precaution, where the drives can be reintegrated afterwards, with no data loss.

Download the My Cloud OS3 firmware for your NAS from the WD website, and save it to your computer. Be certain to verify that you have the correct My Cloud OS3 firmware bin file before proceeding.

Power on the NAS, then connect via SSH and log in (user: sshd) to get a Linux command prompt. An SSH client such as Putty is required. Execute the following commands, which will erase the Linux kernel and system settings, thus triggering the “Safe Mode” after a reboot, where new firmware may be uploaded. The commands must be executed ONE LINE AT A TIME , not all at once.

Erase Linux kernel:

mkdir /tmp/wdnas_kernel
mount /dev/mmcblk0p2 /tmp/wdnas_kernel
rm -f /tmp/wdnas_kernel/uImage

Erase Config Files and Backups:

rm -rf /usr/local/tmp_wdnas_config/*
mkdir /tmp/wdnas_backup
mount /dev/mmcblk0p9 /tmp/wdnas_backup
rm -rf /tmp/wdnas_backup/*

WARNING: Carefully type the commands exactly as shown above, and don’t touch /dev/mmcblk0p1 or /dev/mmcblk0p5. The following is is a list of the eMMC partitions, for reference only.

/dev/mmcblk0p1 "wdnas_efi"
/dev/mmcblk0p2 "wdnas_kernel"
/dev/mmcblk0p3 "wdnas_initramfs"
/dev/mmcblk0p4 "wdnas_image.cfs"
/dev/mmcblk0p5 "wdnas_rescue_fw"
/dev/mmcblk0p6 "wdnas_config"
/dev/mmcblk0p7 "wdnas_reserve1" (hidden)
/dev/mmcblk0p8 "wdnas_reserve2" (hidden)
/dev/mmcblk0p9 "wdnas_backup"

Simply power off the NAS, then power it on again, giving it time to finish booting into “Safe Mode”. Afterwards, connect to it via a web browser using the IP address. A “Safe Mode” firmware upload page should become available, where you can manually upload the OS3 firmware, as appropriate for your NAS.

WARNING: If you assigned a static IP address using the NAS, it won’t work because it was erased when the config files were deleted as part of the reversion process. The NAS will be assigned a new IP address by the router via DHCP. Log into the router and determine what the new IP address is, then use that to connect to the NAS with a browser. If you have trouble uploading new firmware, try a different browser.

_20201210_155321

After uploading the OS3 firmware, and the NAS has finished rebooting, power it off again and reinsert the hard drives. Power on the NAS, where all installed hard drives should now have a red status light after the boot process has finished. Connect to the dashboard via a web browser using the IP address and a “RAID Roaming” message should appear after logging in. Click “OK” to integrate the hard drives, without data loss. Afterwards, the status light for each installed hard drive should turn blue.

The process is now complete.

11 Likes

Works like a charm , tested on both PR4100 and PR2100
Since I am a complete noob on all this, and for the other noobs:

Download some app called putty, for pc server ssh connection
enable ssh in WD
when you open putty, user name is: sshd (and not root or admin etc)
when you type the password , the cursor does not move, so type the password and click enter on keyboard
then write each phrase [dswv42]explained

PS: Before I did all this, Both PRX100 had rebuild raid switched to ON
so when introducing the HDD’s , the system rebuilt raid by itself

and I had the same error on both NAS when I entered:

mkdir /tmp/kernel
mount /dev/mmcblk0p2 /tmp/kernel
rm -f /tmp/kernel/uImage
rm -rf /usr/local/tmp_wdnas_config/*
/usr/sbin/rebootemphasized text

the error was:
failed to load external entity “/etc/NAS_CFG/ftp.xml”
cat: can’t open ‘/etc/exports’: No such file or directory

but it did not matter, because I rebooted the machines and all is well

you have to download the OS3 version before all this also, to then revert

thank you very much DSWV42

That’s odd, I never got that reboot error during testing. However, the reboot command is in fact a custom WD program, so anything is possible. In any case, the error is of no consequence because the configuration files it’s looking for are removed during the reversion process.

Strictly speaking, the reboot command isn’t required. One can also simply power off the machine, then power it back on, which works just as well. I’ve revised the instructions and removed reference to the reboot command, so it doesn’t cause any confusion.

Good points. I’ve also revised the instructions to include downloading the correct firmware, with a link to the WD website, and instructions regarding SSH clients and the correct login username. I use SSH (Putty) every day, so it’s easy to take it for granted.

.

Happy to report I was able to revert back to OS3 thanks to @dswv42 clear instructions. Hard disks have been asleep while I’ve been asleep (as it should be). This thread should be made sticky by WD.

1 Like

Role back worked, I can access all my files etc but am unable to access the dashboard from the ip.

When I type in user name as admin and the password area as blank it does nothing but if you type in the wrong admin name the GUI says its incorrect.

I have tried the 4 second and 40 second reset to no avail.

Any thoughts how to gain access to the dashborad?

Kind Regards

I’m not sure what could have happened, but both versions of the My Cloud OS can be wierd sometimes. Let me see what I can dig up, I’m sure it’s something simple. By the way, the 4 and 40 second password reset procedures can be tricky to get just right.

It finally worked had to 4sec reboot a few times then managed to access! It’s all back to how it was with OS3… thank god

1 Like

Glad you got it working. As I said, those password reset procedures can be tricky.

I think I figured out what was going on. The My Cloud OS3 firmware may have picked up the password files from the config files backup location, likely after it saw that the primary config files were gone. I didn’t have the problem, but I had also erased all my system partitions except for the rescue partition.

I’ve revised the instructions and added 3 additional steps to erase the config file backups, which are not compatible with My Cloud OS3 after a downgrade from My Cloud OS5.

Yes I think you are right… I did notice before I manage to get back in the dashboard it never came up with the raid roaming it just all worked and some of the settings once I was got back in were still as they were before!

Thank you though for this… I’m sure a lot of ppl will be using this :ok_hand:t2::+1:t2:

Hi everyone! I´m new to this forum and I hope you can help me: I´d like to know if there´s any chance that this method works with My Cloud Mirror Gen 2? I was close to try it but to be honest I´m too scared that I might damage anything.
Thanks for your help in advance :slight_smile:

The disclaimer in my instructions clearly state… "this specific process of reverting back to OS3 only works on the PR4100 and PR2100. It should NOT be attempted on any other NAS model.

However, I recently bought a My Cloud EX2 Ultra for testing, and plan to eventually develop a reversion process for it and the My Cloud Mirror Gen 2, as time permits.

3 Likes

Thank you for your answer :+1:

Thanks so very much for this! I just moved back to OS3. All the best during this season for you! Much thanks.

I’m constantly reminded of just how selfless many are with their time and skill.

3 Likes

Mods, can we mark this thread as sticky please? I’m sure lots of OS5 victims are looking for a way to upgrade their devices. Even from WD’s perspective it makes sense for folks to see this thread and know the option exists rather than go and add bash you up on 5 different threads for the disaster that’s OS5

1 Like

My Ex2 Ultra never came to life after trying to rollback to OS3.

Maybe there are options to fix it yourself? I connect to the local ip, safemode, I throw the firmware - I think the download wheel is spinning - the result is zero (((
21637597
I found information in this thread that if the firmware version is not indicated in safemode here, then it will not work to load the firmware via the interface. How to be?
21637207

Exactly what did you do while trying to revert back to OS3? What commands did you use?

It appears that your rescue firmware may be damaged. Can you post a link to the post about the rescue firmware version being missing?

nandwrite /dev/mtd3 /mnt/HD/HD_a2/Downloads/image.cfs

image.cfs was from MyCloud Gen2

Sorry, where do you need to mark the post?

This is likely the source of your problem. You can’t use an image.cfs file from a different My Cloud model. Only an image.cfs file from a My Cloud EX2 Ultra will work.

The image.cfs file varies in size between different My Cloud models, and the MyCloud Gen2 image.cfs file you used likely exceeded the available space in the My Cloud EX2 Ultra /dev/mtd3 NAND partition, thus overwriting part of the /dev/mtd4 NAND partition, which contains the rescue firmware. In other words, you corrupted your rescue firmware.

/dev/mtd0 ---> "U-Boot" (bootloader)
/dev/mtd1 ---> "uImage" (kernel)
/dev/mtd2 ---> "uRamdisk" (initramfs)
/dev/mtd3 ---> "image.cfs" (root filesystem)
/dev/mtd4 ---> "rescue fw" (rescue firmware)
/dev/mtd5 ---> "config" (config files)
/dev/mtd6 ---> "reserve1"
/dev/mtd7 ---> "reserve2"

It likely would not have worked anyway, because the MyCloud Gen2 root filesystem (image.cfs) is compiled to run on different hardware with a different Linux kernel.

can it be repaired?